Forum bépo

Forum des utilisateurs du bépo

Vous n'êtes pas identifié(e).

#1 Re : Assistance utilisateurs » [RÉSOLU] Perte de configuration à chaque démarrage » 11/11/2016 17:29:09

Laurent a écrit :

Clique sur le carré « Fr » de la barre en haut.
Dans le menu, choisis « Paramètres de saisie de texte… ».
Clique sur « Paramètres du clavier… » en bas à droite de la fenêtre.
Clique sur le champ à droite de « Touche de composition » et sélectionne « Désactivé »


P***N !

Je suis passé dessus 200 fois, sans jamais le voir !!! La honte m'assaille ! Quel boulet ! tongue

Merci mille fois smile

#2 Re : Assistance utilisateurs » [RÉSOLU] Perte de configuration à chaque démarrage » 11/11/2016 13:54:15

Laurent a écrit :

Par ailleurs, « compose(ralt) » indique que tu as Compose sur AltGr. C’est pour ça que tu n’as plus AltGr dessus ! Après, avec Compose, tu peux faire par exemple « œ » avec Compose o e, mais pour faire « _ », ça va être moins pratique…

Je ne sais même pas exactement ce qu'est la touche Compose… hmm

Laurent a écrit :

Je n’ai pas d’Unity ou de Gnome sous la main en ce moment, mais quelque part dans leurs réglages clavier, il y en a un pour choisir où placer (éventuellement) la touche Compose. Il faut que tu choisisses autre chose qu’AltGr (sachant que la touche choisie est « sacrifiée ») ou rien du tout si tu n’a pas l’utilité de Compose.


Sais-tu quel fichier je dois éditer pour gicler ce "ralt" ? Je ne trouve rien dans les menus de configuration qui permette de modifier ça…

#3 Re : Assistance utilisateurs » [RÉSOLU] Perte de configuration à chaque démarrage » 11/11/2016 10:57:55

Laurent a écrit :

Bonjour,


C’est le programme qui adapte la disposition X.org en disposition pour la console texte (celle qu’on obtient par exemple en tapant Ctrl+Alt+2 — Ctrl+Alt+F7 ou Ctrl+Alt+F1 pour revenir à la console graphique) qui signale qu’il n’y a pas d’équivalent à la touche morte caractère grec. À moins que tu veuilles taper des caractères grecs en console, ce n’est pas grave.

Non, je n'utilise pas le grec


Laurent a écrit :

Ton problème est sûrement plutôt situé au niveau de X.
La commande dpkg-reconfigure keyboard-configuration a la particularité d’établir les réglages systèmes sur la session courante.
Si elle règle le problème, ça prouve qu’ils sont bons.

Un autre moyen de valider cette hypothèse : as-tu le problème aussi sur l’écran de connexion ?

Difficile à dire : je n'utilise pas ces touches pour le login. Par ex, que ce soit au 1er login ou après avoir quitté la session, AltGr + Espace dans le champ mot de passe génère bien un point, signifiant par là qu'un caractère est bien pris en compte, mais lequel ? …

Laurent a écrit :

Je pense que tu as plutôt un souci du côté des réglages clavier de ton environnement graphique (lequel est-ce ? Unity, l’environnement par défaut d’Ubuntu ou un autre ?).

C'est Unity.

Laurent a écrit :

Vérifie les réglages à son niveau (si ton environnement est Unity, voir les paragraphes 1 et 2 de cette documentation), pour la disposition, mais aussi pour les raccourcis, notamment ceux pour changer de disposition (tu serais juste le troisième depuis quelques temps à avoir un problème dû à ça…).

Je n'ai aucun changement de disposition, uniquement bépo. Et j'ai procédé pour mon install de 16.04 exactement de la même manière que lors de l'install précédente, qui fonctionnait sans problème… (Et peut-être ai-je mal lu mais je n'y trouve rien qui me paraisse susceptible de  régler mon problème.)

Laurent a écrit :

Cela dit, si tu pouvais nous copier la sortie de la commande

setxkbmap -print

(lancée avant dpkg-reconfigure !), ça nous donnerait sûrement une bonne indication par rapport à ton problème.

Voici ce que retourne setxkbmap -print avant le dpkg :

xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(azerty)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+fr(bepo)+fr(oss):2+us:3+inet(evdev)+compose(ralt)+terminate(ctrl_alt_bksp)"	};
	xkb_geometry  { include "typematrix(tm2030USB)"	};
};

APRÈS la commande dpkg, seule la ligne xkb_symbols change. Voici ce qu'elle devient :

	xkb_symbols   { include "pc+fr(bepo)+inet(evdev)"	};

Merci pour le temps que tu me consacres smile

#4 Re : Assistance utilisateurs » [RÉSOLU] Perte de configuration à chaque démarrage » 10/11/2016 18:09:50

Mimoza a écrit :
Stanzer a écrit :
Your console font configuration will be updated the next time your system boots.

Il t'a prévenu …

Stanzer a écrit :
If you want to update it now, run 'setupcon' from a virtual console.

Tu as essayer la commande qu'il t'indique ?
Si oui ça donne quoi ?

Sinon je n'ai jamais eu ce soucis donc je pourrais difficilement t'aider.

Bien sûr que j'ai essayé ! J'obtiens X fois la ligne "WARNING: Unknown X keysym "dead_greek"

Et c'est tout. Et à chaque redémarrage, Tout est perdu…

#5 Assistance utilisateurs » [RÉSOLU] Perte de configuration à chaque démarrage » 10/11/2016 10:07:13

Stanzer
Réponses : 8

Bonjour,

Depuis 6 à 8 mois, par défaut, mon clavier (TypeMatrix 2030) ne "sait pas reconnaître" les combinaisons de touche avec AltGr. (_, …, trémas, etc…)

Ainsi, je suis obligé, après chaque boot (Ubuntu 16.04) d'entrer la commande

sudo dpkg-reconfigure keyboard-configuration

Qui me retourne des erreurs, mais qui fonctionne…

WARNING: Unknown X keysym "dead_greek"
…
(Répété 16 fois)
…
WARNING: Unknown X keysym "dead_greek"
Your console font configuration will be updated the next time your system
boots. If you want to update it now, run 'setupcon' from a virtual console.
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
update-initramfs: deferring update (trigger activated)
Traitement des actions différées (« triggers ») pour initramfs-tools (0.122ubuntu8.5) ...
update-initramfs: Generating /boot/initrd.img-4.4.0-47-generic

Quelqu'un pourrait-il m'indiquer une piste de recherche ?

Merci d'avance.

#6 Re : Assistance utilisateurs » [RÉSOLU] Les touches mortes… "ne sont plus mortes" » 23/8/2016 09:41:17

On m'a suggéré (en dehors du forum)

sudo dpkg-reconfigure keyboard-configuration

et voilà… Magie… problème réglé.

#8 Re : Assistance utilisateurs » [RÉSOLU] Les touches mortes… "ne sont plus mortes" » 22/8/2016 18:09:28

Merci pour la suggestion.

Je l'ai fait, et aucun soucis. Mais étant donné que les applications Qt ne sont pas touchées, j'avais d'ores et déjà éliminé cette possibilité.

#9 Re : Assistance utilisateurs » [RÉSOLU] Les touches mortes… "ne sont plus mortes" » 22/8/2016 08:32:28

Au redémarrage ce matin, le problème est réapparu. Mais cette fois, aucune des manipulations que j'ai pu effectuer hier ne semble fonctionner.

Je suis preneur de toute piste. Merci d'avance.

#10 Re : Assistance utilisateurs » [RÉSOLU] Les touches mortes… "ne sont plus mortes" » 21/8/2016 13:09:23

Le problème est résolu. Mais je ne saurais pas dire comment.

Je me suis contenté d'ajouter le layout "bépo Latin-9 uniquement", de basculer entre les deux, et de redémarrer…

Reste à savoir si ça va tenir. En attendant, je marque le topic comme résolu.

#11 Assistance utilisateurs » [RÉSOLU] Les touches mortes… "ne sont plus mortes" » 21/8/2016 11:50:17

Stanzer
Réponses : 8

Bonjour,

[EDIT 22.08] Après avoir fonctionné une journée (cf post 2), impossible ce matin de taper correctement les caractères mentionnés]


Sans raison apparente, les touches mortes de mon clavier (typematrix) ne fonctionnent plus comme elles sont sensées le faire. Ceci ne s'applique qu'aux applications GTK. Tout fonctionne avec Qt : ex notepadqq

Exemple : ^e ; ¨i ;´e ; ~… etc, etc

Ce comportement a changé ce matin, sans que j'aie effectué la moindre modification sur ma machine (Ubuntu 16.04) pas de mise à jour, pas d'installation de nouveau programme, etc… Il est fort probable que j'aie tapé une mauvaise combinaison de touche, mais laquelle ?

Voici ce que me retourne xev quand je frappe la touche ^

KeyPress event, serial 37, synthetic NO, window 0x4e00001,
    root 0x4a4, subw 0x0, time 1821181, (16,-14), root:(63,847),
    state 0x10, keycode 29 (keysym 0xfe52, dead_circumflex), same_screen YES,
    XLookupString gives 1 bytes: (5e) "^"
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: True

KeyRelease event, serial 37, synthetic NO, window 0x4e00001,
    root 0x4a4, subw 0x0, time 1821325, (16,-14), root:(63,847),
    state 0x10, keycode 29 (keysym 0xfe52, dead_circumflex), same_screen YES,
    XLookupString gives 1 bytes: (5e) "^"
    XFilterEvent returns: False

Je vous remercie d'avance pour toute l'aide que vous pourrez m'apporter…

S.

#12 Re : Assistance utilisateurs » [Résolu] TypeMatrix 2030 - Pavé numérique » 11/3/2016 15:44:41

Laurent a écrit :

Je vois deux possibilités pour régler le problème dans l’immédiat :
– brancher un clavier classique (avec un pavé numérique physique), taper sur Verr. Num. dessus et le débrancher ;
– utiliser la commande numlockx off.

Woahou ! big_smile

Ça marche. J'avais en effet branché un second clavier azerty pour booter dans une VM avec un MdP tordu que j'avais entré en qwery sans le savoir. Et j'avais effectivement dû passer par VerrNum pour activer le pavé numérique sur ce second clavier, alors qu'il était évidemment déjà activé sur la machine hôte. J'imagine donc que c'est en faisant cette manip que ça a inversé le numlock de l'hôte.

J'ai donc rebranché ce second clavier, tapé VerrNum, et voilà, tout est revenu à la normale. Merci d'avoir pris le temps de rédiger une réponse aussi longue et précise.

Je vais aussi poster ta réponse en lien sur le forum Typematrix où j'avais aussi posé cette question (mais en anglais).

Merci bcp, cool

Stan.

#13 Re : Assistance utilisateurs » [Résolu] TypeMatrix 2030 - Pavé numérique » 11/3/2016 10:00:10

Laurent a écrit :

Bonjour,

Si tu démarres sur un système live sur clé USB, as-tu le même souci (c’est pour écarter un problème matériel) ?

Peux-tu créer un autre compte utilisateur pour tester (au cas où ce serait lié à des paramètres de ton compte) et voir si ça le fait aussi avec lui ?

Aucun problème en USB, ni avec un nouveau compte de test, où tout foctionne.

Laurent a écrit :

Qu’indique la commande setxkbmap -print ?

~$ setxkbmap -print

xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(azerty)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+fr(bepo)+inet(evdev)"	};
	xkb_geometry  { include "pc(pc105)"	};
};

Voici ce que me donne la même commande dans le compte de test où tout fonctionne normalement :

	
xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(azerty)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+fr(bepo)+fr(oss):2+us:3+inet(evdev)"	};
	xkb_geometry  { include "pc(pc105)"	};
};
Laurent a écrit :

Qu’as-tu comme trace avec xev ?

Voici ce que retourne xev, en tapant sur le pavé successivement (Fn + 1 2 3), puis (Fn + Maj + 1 2 3)

KeyPress event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2668072, (102,-14), root:(1842,38),
    state 0x0, keycode 87 (keysym 0xff9c, KP_End), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2668208, (102,-14), root:(1842,38),
    state 0x0, keycode 87 (keysym 0xff9c, KP_End), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2668296, (102,-14), root:(1842,38),
    state 0x0, keycode 88 (keysym 0xff99, KP_Down), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2668440, (102,-14), root:(1842,38),
    state 0x0, keycode 88 (keysym 0xff99, KP_Down), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2668504, (102,-14), root:(1842,38),
    state 0x0, keycode 89 (keysym 0xff9b, KP_Next), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2668592, (102,-14), root:(1842,38),
    state 0x0, keycode 89 (keysym 0xff9b, KP_Next), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2679384, (102,-14), root:(1842,38),
    state 0x0, keycode 50 (keysym 0xffe1, Shift_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2679880, (102,-14), root:(1842,38),
    state 0x1, keycode 87 (keysym 0xffb1, KP_1), same_screen YES,
    XLookupString gives 1 bytes: (31) "1"
    XmbLookupString gives 1 bytes: (31) "1"
    XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2680008, (102,-14), root:(1842,38),
    state 0x1, keycode 87 (keysym 0xffb1, KP_1), same_screen YES,
    XLookupString gives 1 bytes: (31) "1"
    XFilterEvent returns: False

KeyPress event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2680112, (102,-14), root:(1842,38),
    state 0x1, keycode 88 (keysym 0xffb2, KP_2), same_screen YES,
    XLookupString gives 1 bytes: (32) "2"
    XmbLookupString gives 1 bytes: (32) "2"
    XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2680224, (102,-14), root:(1842,38),
    state 0x1, keycode 88 (keysym 0xffb2, KP_2), same_screen YES,
    XLookupString gives 1 bytes: (32) "2"
    XFilterEvent returns: False

KeyPress event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2680336, (102,-14), root:(1842,38),
    state 0x1, keycode 89 (keysym 0xffb3, KP_3), same_screen YES,
    XLookupString gives 1 bytes: (33) "3"
    XmbLookupString gives 1 bytes: (33) "3"
    XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2680456, (102,-14), root:(1842,38),
    state 0x1, keycode 89 (keysym 0xffb3, KP_3), same_screen YES,
    XLookupString gives 1 bytes: (33) "3"
    XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2680728, (102,-14), root:(1842,38),
    state 0x1, keycode 50 (keysym 0xffe1, Shift_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

FocusOut event, serial 37, synthetic NO, window 0x5600001,
    mode NotifyGrab, detail NotifyNonlinear

FocusIn event, serial 37, synthetic NO, window 0x5600001,
    mode NotifyUngrab, detail NotifyNonlinear

KeymapNotify event, serial 37, synthetic NO, window 0x0,
    keys:  2   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   

Merci pour ton aide

#14 Assistance utilisateurs » [Résolu] TypeMatrix 2030 - Pavé numérique » 10/3/2016 19:54:38

Stanzer
Réponses : 6

Bonjour,

C'est encore moi, avec un nouveau problème…

Depuis que j'ai installé ma nouvelle tablette Wacom, le fonctionnement du pavé numérique a changé. Je ne suis pas certain que ça soit lié, mais étant donnée la concomitance des deux événements, je présume que si.

Désormais, je dois – en plus de Fn ou VerrNum – presser la touche Maj pour obtenir mes chiffres par le pavé. Mais ce comportement n'apparaît qu'une fois loggé. En effet, sur l'écran de connexion LightDM, le fonctionnement du pavé est « normal ».

Je précise que j'ai dû compiler les pilotes de la tablette (elle est trop récente pour être reconnue), et que donc, je ne peux pas les désinstaller, tout au plus, la débrancher. J'ajoute que peu importe que la tablette soit branchée ou non, le fonctionnement reste identique à ce qui est décrit ci-dessus…

Merci d'avance pour chaque petit bout d'info que vous pourrez me donner à ce sujet.

Stan

#15 Re : Assistance utilisateurs » Problème touche Alt Gr » 7/3/2016 18:56:04

bobo38 a écrit :

C'est difficile à documenter, c'est clair… Je ne suis même pas sûr de voir comment reproduire le bug de mon côté (il faudrait que je relise tout dans le détail).

J'ai une approche de l'isolation de bug par dichotomie. Ce qui pourrait être pas mal ce serait d'utiliser dans une de tes virtualbox un autre gestionnaire de connection (slim par exemple), et l'utiliser en autologin, et voir si le soucis est disparaît bel et bien. Si oui, le soucis vient bel et bien de lightdm. Si non, ce pourrait être plus tordu.


Oui, pas con. Je vais essayer ça… dès que j'aurais un moment. smile

#16 Re : Assistance utilisateurs » Problème touche Alt Gr » 7/3/2016 18:44:59

Stanzer a écrit :

Quant à savoir si c'est un bug ou un pb venant de moi, je ne sais pas trop. Je vais faire un test avec une install propre ds une VM, voir si ça se reproduit… et je vous tiens au courant. cool

Je viens donc de faire des tests avec Virtualbox. J'ai testé ubuntu 15.10 et la beta la plus récente de 16.04. Dans les deux cas, lors d'une connexion automatique, le problème cité en objet réapparaît… et se corrige quand on se logge manuellement. Je pense donc qu'il s'agit d'un bug, mais je ne sais pas trop comment appréhender le problème pour remplir un rapport…

À suivre, donc.

#17 Re : Assistance utilisateurs » Deux questions bêtes : chiffres en indice et le º souligné de N°… » 7/3/2016 17:59:05

Mimoza a écrit :

Il faut voir ce caractère comme une flèche qui pointe vers le bas et le «^» (accent circonflexe) comme une flèche qui pointe vers le haut. Du coup tu sais intuitivement si tu obtient un indice  «¹²³» ou un exposant «₁₂₃»
Enfin c'est mon point de vue big_smile

Houuuuuuu ! C'est rudement intelligent…

Blague à part, oui, c'est pas bête, comme raisonnement. Mais j'ai bien fait de demander, je n'aurais jamais trouvé ça tout seul…

Merci pour le moyen mnémotechnique. tongue

#18 Re : Assistance utilisateurs » Deux questions bêtes : chiffres en indice et le º souligné de N°… » 7/3/2016 09:58:43

Laurent a écrit :

Elle consiste à créer dans ton répertoire un fichier .XCompose contenant :

# IMPORTANT : chargement de la configuration de Compose de la locale
include "%L"

# Abréviations pour numéro(s)
<dead_circumflex> <n> <o> : "nᵒ"
<dead_circumflex> <N> <o> : "Nᵒ"  # Majuscule en début de phrase
<dead_circumflex> <N> <O> : "Nᵒ"
<dead_circumflex> <n> <s> : "nᵒˢ" # Pluriel
<dead_circumflex> <N> <s> : "Nᵒˢ"
<dead_circumflex> <N> <S> : "Nᵒˢ"

Il permet d’obtenir nᵒ en tapant accent circonflexe n o, nᵒˢ en tapant accent circonflexe n s…

Certains logiciels pourraient ne pas prendre en compte le fichier .XCompose (note qu’il n’est pris en compte que par les logiciels lancés après sa création ou modification). Dans ce cas, il faudrait sélectionner xim comme méthode de saisie dans la configuration du clavier de ton environnement graphique (pour peu qu’elle propose de sélectionner la méthode de saisie) ou avec im-config (sous Ubuntu, sinon voir ).


Ça c'est le genre de bidouillage que je suis disposé à essayer. (Ahem, si tant est qu'un copier/coller soit un bidouillage tongue) Ça marche impeccablement. Merci smile

#19 Re : Assistance utilisateurs » Deux questions bêtes : chiffres en indice et le º souligné de N°… » 7/3/2016 09:16:51

Mimoza a écrit :

La solution est assez logique au final. Si tu regarde la carte complète (passe la sourie sur l'image) du Bépo tu verra que sur le «V» en AltGr il y a «ˇ» comme touche morte. Donc pour mettre en indice il faut que tu fasse AltGr + V + <ce que tu veux mettre en indice>.

Je n'aurais pas trouvé ça tout seul. Je dois rater quelque chose, car je n'arrive pas à comprendre en quoi il y a une logique là-dedans : je ne connaissais pas le ˇ, mais je fais mal le lien entre un caractère « haut » et un affichage des chiffres en indice ; donc, « en bas »… Bref, peu importe, du moment que ça fonctionne… tongue

Pour le «º» souligné il est sur le AltGr + Shift + m, mais attention le rendu dépend de la police de caractère, par exemple sur le forum je n'arrive pas à l'obtenir via la combinaison de touche que je t'ai indiqué, alors que dans un éditeur de texte pas de soucis.

J'ai testé avec différentes polices dans LibreOffice, j'obtiens juste un º, mais jamais souligné. Bah, ce n'est qu'un détail. Il s'agissait plus de curiosité que d'un besoin réel.

Merci beaucoup d'avoir pris la peine de me répondre avec autant de détails smile

#20 Re : Assistance utilisateurs » Deux questions bêtes : chiffres en indice et le º souligné de N°… » 7/3/2016 09:07:12

bobo38 a écrit :

Je viens de retrouver après un dernier essai : CO₂ !

Tu fais Alt+V, puis le chiffre, et voilà. C'est la touche « dead_caron » (accessible par Alt+V), dans /usr/share/X11/xkb/symbols/fr :

key <AD07> { [               v,            V,     dead_caron                 ] }; // v V ˇ

Merci pour ta réponse rapide. smile

#21 Assistance utilisateurs » Deux questions bêtes : chiffres en indice et le º souligné de N°… » 6/3/2016 23:03:17

Stanzer
Réponses : 9

bonjour,

je viens de passer 1h30 sur toutes les pages du site et une dizaine de threads du forum…

j'ai vu ici que bépo permettait de mettre les chiffres en indice ; j'ai bien vu sur cette page du forum qu'il existe des modifiers, mais voilà, impossible d'en savoir plus.

En bref, j'ai compris par hasard comment mettre les chiffres en exposant, mais pas en indice. Pouvez-vous m'en dire plus ?

Deuxième question :

j'ai croisé – dans un post que je n'ai pas réussi à retrouver – l’abréviation de « numéro » avec un petit ° (ou º) souligné… Comment obtenir ce caractère ?

Merci d'avance pour l'aide que vous pourrez m'apporter sur ces deux questions, sachant que :

1. je ne suis pas (encore) disposé à trifouiller mes fichiers de config (Linux) et
2. j'espère que mon état de fatigue ne m'a pas fait rater des évidences…

smile

#22 Re : Assistance utilisateurs » Problème touche Alt Gr » 6/3/2016 13:42:13

bobo38 a écrit :

C'est dingue ça. C'est quoi ton gestionnaire de connection : gdm ? kdm ? lightdm ? slim ?
Ça pourrait valoir le coup de voir si c'est un bug ou un soucis de configuration…

C'est lightdm.

Quant à savoir si c'est un bug ou un pb venant de moi, je ne sais pas trop. Je vais faire un test avec une install propre ds une VM, voir si ça se reproduit… et je vous tiens au courant. cool

#23 Re : Assistance utilisateurs » Problème touche Alt Gr » 6/3/2016 10:49:00

Laurent a écrit :

Si tu ouvres la première session en sélectionnant un autre environnement de bureau (il faudra probablement en installer un avant ; LXDE est léger, il ne devrait pas prendre trop de place), le problème est-il le même ?

Suite à ton post, je me suis dit :

« bon, plan de bataille :
1 - installer XFCE, et … ah, oui, au fait, du coup, il faut que je désactive la connexion automatique pour pouvoir ensuite choisir l'envir… mais, mais, mais… et si … ? 
»

En effet, pour la première fois de ma vie, lors de la réinstall de janvier, j'avais opté pour le login auto. Je désélectionne donc cette option et reboote la machine…

Et là, miracle, tout fonctionne.

C'est donc le login automatique qui devait bypasser un fichier de config quelconque…

Problème résolu !

Mille mercis pour les pistes que tu m'as fournies smile smile smile

#24 Re : Assistance utilisateurs » Problème touche Alt Gr » 6/3/2016 10:03:33

Laurent a écrit :

As-tu lancé im-config avec sudo ou pas ?

Oui, j'ai aussi essayé ça

Question subsidiaire par rapport à im-config : apparemment tu mets sur xim (c’est ce que je conseille), mais est-ce déjà ce qui est sélectionné avant ? Sinon qu’est-ce que c’est ?

c'est toujours "defaut" qui est sélectionné, quoi que j'aie choisi avant

Par ailleurs, im-config, ça influence habituellement le comportement des touches mortes, pas de AltGr (à moins qu’une méthode de saisie très particulière le fasse…). Si tu fermes ta session et que tu la réouvres sans lancer im-config entre les deux, le problème persiste-t-il ou pas ?

REDOUTABLE : en effet, pas besoin d'imconfig, une simple réouverture de session corrige le problème…

#25 Re : Assistance utilisateurs » Problème touche Alt Gr » 6/3/2016 09:57:13

Merci pour le suivi smile


Exemple de la page web tweetdeck.com (qui m'intrigue le plus, car selon que je réponde dans le fil de la conversation ou que je compose un nouveau tweet, le résultat diffère)

Quand j'allume ma machine et lance firefox, si je veux taper dans un nouveau tweet n'importe quelle combinaison de touches comprenant AltGr (ǜ | … ù æ < > œ) le résultat est le même que si je pressais la touche "échap" : AltGr me fait perdre le focus. (sans que je sois capable de déterminer quel élément le récupère)
altgr

En revanche, si je réponds dans le fil de la conversation, je n'ai aucun souci, tout fonctionne.
altgr

Second exemple Filezilla : Quand je modifie un fichier, je renomme l'original en mettant un "_" devant. Et là, également – avec le nom sélectionné par F2 – dès que je presse AltGr, le nom de fichier se désélectionne, exactement le même comportement que "esc".

Pour palier cet écueil, je fais im-config -c , et sélectionne soit "defaut", soit "xim", le résultat est le même : ça fonctionne après relance de la session.

J'ai aussi testé "Remove" cf image ds mon 1er post. Il n'y a qu'iBus que je n'aie pas testé, car inutile dans mon cas, d'après ce que j'ai pu lire ça et là.

À votre disposition pour plus de détails…

Pied de page des forums

Propulsé par FluxBB