Forum bépo

Forum des utilisateurs du bépo

Vous n'êtes pas identifié(e).

#1 28/11/2009 19:07:30

Cristian
Membres
Lieu : Brabant Wallon, Belgique
Inscription : 14/11/2009
Messages : 27

[windows] Problème pour changer de disposition sous XP

Salut tout le monde,

Je passe encore presque tout mon temps en azerty. Mais quand je veux me mettre en bépo je dois aller dans le panneau de configuration car la combinaison alt+maj que j’utilise habituellement pour switcher entre azerty et qwerty ne fonctionne pas pour passer au bépo car il ne se trouve pas dans la liste des dispositions. Et quand je veux revenir en azerty, je ne peux pas non plus utiliser alt+maj car en me mettant en azerty « Français (France) » je reviens en bépo (en fait on dirait qu’il reste en azerty Français même en bépo). Par contre, toujours alors que je suis en bépo et que, toujours via cet alt_maj je me mets en azerty « Français (Belgique » ou en qwerty « Espagnol (Chili) », là il passe bien dans la disposition demandée.

Ce petit détail m’énerve car bien que j'habite la Belgique, j'utilise la disposition française pour taper en français et anglais. Et donc me mettre en azerty Belge pour pâlier le problème que quand je suis en bépo et que je me mets en azerty Français ça reste en bépo ne me convient pas.

Bien sûr il y a le panneau de configuration. Mais là encore il y a un problème, c’est qu’on dirait que ça ne passe pas tout de suite en azerty. Enfin c’est bizarre et je ne comprends pas encore très bien son comportement à ce niveau-là.

J’ai désinstallée et réinstallée la disposition bépo et c’est toujours pareil. Quelqu’un comprend-il ce qu’il se passe ?

Bon week-end !

Dernière modification par Cristian (28/11/2009 19:09:10)

Hors ligne

#2 30/11/2009 20:13:26

bgse
Membres
Inscription : 4/8/2009
Messages : 144

Re : [windows] Problème pour changer de disposition sous XP

je suis peutêtre complètement à coté de la plaque, mais sais-tu que quand tu fais alt+maj, ça n'est valable que dans la fenêtre dans laquelle tu te trouves au moment où tu le fais ?
autrement dit, si tu ulitises firefox + openoffice + vl, et que tu te trouves sur firefox au premier plan quand tu fais alt+maj, openoffice et vlc restent dans ta première configuration de clavier et ne passent pas dans la deuxième.

sinon, moi au boulot je n'utilise pas le driver, mais le logiciel pkl :
http://bepo.fr/wiki/Portable_Keyboard_Layout
pour passer d'azerty au bépo (valable pour toutes les applications ouvertes et à ouvrir), il me semble qu'il y a des raccourcis (que je n'utilise pas puisque je suis toujours en bépo).

Hors ligne

#3 3/12/2009 18:11:38

Cristian
Membres
Lieu : Brabant Wallon, Belgique
Inscription : 14/11/2009
Messages : 27

Re : [windows] Problème pour changer de disposition sous XP

bgse a écrit :

je suis peutêtre complètement à coté de la plaque, mais sais-tu que quand tu fais alt+maj, ça n'est valable que dans la fenêtre dans laquelle tu te trouves au moment où tu le fais ?

Oui. Mais même dans la fenêtre où je me trouve, alt+maj est inopérant : si je suis en Français (France), ça passe par l’espagnol (Chili), le Français (Belgique) et on revient au Français (France).

En lisant un autre post j’ai découvert CTRL+maj, qui fonctionne. Même ça c’est un peu aléatoire (parfois tout à coup ça repasse en azerty) mais ça va déjà mieux.

sinon, moi au boulot je n'utilise pas le driver, mais le logiciel pkl :
http://bepo.fr/wiki/Portable_Keyboard_Layout
pour passer d'azerty au bépo (valable pour toutes les applications ouvertes et à ouvrir), il me semble qu'il y a des raccourcis (que je n'utilise pas puisque je suis toujours en bépo).

Merci, je vais aller voir ça.

Hors ligne

#4 7/12/2009 17:06:31

JF
Modo
Lieu : Charleroi
Inscription : 6/12/2009
Messages : 175

Re : [windows] Problème pour changer de disposition sous XP

En ce qui concerne le choix d’une disposition de clavier, le panneau de configuration ne sert qu’à installer / désinstaller des langues d’entrée et des dispositions de clavier, et à leur associer des combinaisons de touches. Leur activation se fait par l’intermédiaire de la barre de langues (qui, par défaut, est réduite dans la zone de notification, en bas à droite de l’écran, près de l’horloge) ou par les combinaisons de touches.

En fait, Windows distingue les langues d’entrée et les dispositions de clavier.
Par défaut, Windows propose la combinaison de touches Alt + Maj pour changer de langue et Ctrl + Maj pour changer de disposition.

D’après ce que tu as décrit, tu as installé 3 langues : Français (France), Espagnol (Chili) et Français (Belgique).
La combinaison Alt + Maj te permet de passer de l’une à l’autre de ces 3 langues, et rien de plus.

Pour la langue Français (France), tu as deux dispositions de clavier : Français et une autre dont le nom commence par fr-dvorak-bépo.
La combinaison Ctrl + Maj te permet de passer de l’une à l’autre de ces dispositions, mais seulement lorsque la langue correspondante, Français (France) est active.

Il m’est souvent arrivé de changer de langue et / ou de clavier sans le vouloir, en utilisant des raccourcis du genre Ctrl + Maj + flèche de déplacement du curseur vers le haut pour sélectionner le texte depuis le curseur jusqu’au début du paragraphe.
J’ai fini par désactiver les raccourcis Alt + Maj et Ctrl + Maj, et, à chaque paire langue / disposition de clavier, j’ai associé une combinaison de touches du type Ctrl + Maj + une touche de la rangée des chiffres.

C’est dans le Panneau de configuration que ça se passe.
Avec l’affichage classique : options régionales et linguistiques, onglet Langues, bouton Détails.
Ça ouvre la boîte de dialogue Services de texte et langues d’entrée.
Cliquer sur Paramètres de touches : ça ouvre une nouvelle boîte de dialogue Paramètres de touches avancés.
Là, il y a une liste qui commence par « Basculer entre les langues d’entrée ». Un double clic permet d’ouvrir une boîte de dialogue où l’on peut choisir la combinaison de touches pour « Modifier la langue d’entrée » ou « Modifier la disposition du clavier ». Pour chacune, on peut choisir entre Alt + Maj et Ctrl + Maj, et on peut désactiver la combinaison.
Les autres éléments de la liste sont de la forme Basculer vers <nom de la langue> - <nom de la disposition>.
Un double clic permet de choisir une combinaison de trois touches : la première touche peut être Ctrl ou Alt gauche, la deuxième touche est nécessairement Maj, et la troisième est 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, ~ ou Accent grave.

Dernière modification par JF (7/12/2009 23:26:46)

Hors ligne

#5 7/12/2009 22:46:43

Cristian
Membres
Lieu : Brabant Wallon, Belgique
Inscription : 14/11/2009
Messages : 27

Re : [windows] Problème pour changer de disposition sous XP

Ah ! Merci JF ! Grâce à toi j'ai enfin compris cette histoire d'alt+maj vs CTRL+Maj !

JF a écrit :

Il m’est souvent arrivé de changer de langue et / ou de clavier sans le vouloir, en utilisant des raccourcis du genre Ctrl + Maj + Home pour sélectionner le texte depuis le curseur jusqu’au début du paragraphe.

Ooooooookayyyyyyyy ! C’est donc ça que ça me change parfois subitement de disposition ! Je vais faire le changement que tu décris.

Un tout grand merci !

Hors ligne

#6 14/1/2010 18:56:26

A2
Admin
Inscription : 29/10/2009
Messages : 138

Re : [windows] Problème pour changer de disposition sous XP

JF, je vais reprendre tes explications détaillées pour le paragraphe du wiki à ce sujet où l'explication est plus que sommaire, quand j'aurais le temps. Il est vrai que la confusion langue/disposition est fréquente.

Dernière modification par A2 (14/1/2010 18:59:24)

Hors ligne

#7 15/1/2010 15:55:59

JF
Modo
Lieu : Charleroi
Inscription : 6/12/2009
Messages : 175

Re : [windows] Problème pour changer de disposition sous XP

Là, je me suis basé sur le XP de ma tour. Sous Vista, c’est légèrement différent, et je n’ai jamais touché à Seven.

Hors ligne

Pied de page des forums