Forum bépo

Forum des utilisateurs du bépo

Vous n'êtes pas identifié(e).

#1 12/7/2015 15:59:38

Flavien21
Admin
Lieu : Versailles
Inscription : 12/7/2015
Messages : 142
Site Web

bépo AT/bópo

Edit : voici la carte simplifié pour ceux qui découvre le topic sur ce premier message :
cartesimplifiee.png

Bonjour,

J’utilise le bépo depuis le début de l’année et j’ai décidé d’y apporter quelque petites modifications.

J’ai principalement inversé ' et ’, et ai ajouté 2 touches mortes, une pour l’alphabet phonétique international en shift+altgr+w et une autre pour une extension de caractère (principalement des ligatures) en shift+altgr+à

J’ai également fait un 2ème clavier adapté pour le catalan et l’occitan qui prend le nom de bópo.

Je détaillerai les modifications plus tard pour les 2 claviers et fournirai les pilotes PC et Mac.

Seulement voilà pour l’instant j’ai un problème sur PC avec la touche morte pour l’extension de caractère, elle ne marche pas.
Quand je fais altgr+maj+à j’ai un bip sonore et il m’affiche le caractère primaire après.
J’ai tenté de changé le terminateur ainsi que de déplacer la touche en altgr+maj+̂ mais même résultat, ça ne marche pas.
Ce qui est étonnant c’est que la touche pour l’API fonctionne très bien et qu’elle a été faite de la même manière.
En éditant le .klc avec le bloc note pourtant rien ne choque, elle ressemble exactement aux autres.

La touche en elle même ressemble à ça :

2c	OEM_6		1	00e0	00c0	-1	005c	0238@	

Et la touche morte à ça :

DEADKEY	0238

0024	266d	// $ -> ♭
0023	266f	// # -> ♯
2013	266e	// – -> ♮
0022	2015	// " -> ―
00ab	2039	// « -> ‹
003c	27e8	// < -> ⟨
00bb	203a	// » -> ›
003e	27e9	// > -> ⟩
0028	2e24	// ( -> ⸤
0034	2e22	// 4 -> ⸢
005b	231e	// [ -> ⌞
2264	231c	// ≤ -> ⌜
0029	2e25	// ) -> ⸥
0035	2e23	// 5 -> ⸣
005d	231f	// ] -> ⌟
2265	231d	// ≥ -> ⌝
002b	205c	// + -> ⁜
0037	203b	// 7 -> ※
002d	261e	// - -> ☞
0038	3059	// 8 -> す
002f	2234	// / -> ∴
0039	307f	// 9 -> み
00f7	2235	// ÷ -> ∵
002a	2042	// * -> ⁂
0030	307e	// 0 -> ま
003d	25cc	// = -> ◌
00b0	305b	// ° -> せ
0025	2034	// % -> ‴
0060	3093	// ` -> ん
2030	2057	// ‰ -> ⁗
0042	a796	// B -> Ꞗ
0062	0238	// b -> ȸ
0070	0239	// p -> ȹ
0050	13a4	// P -> Ꭴ
0026	2117	// & -> ℗
00a7	204a	// § -> ⁊
006f	0153	// o -> œ
004f	0152	// O -> Œ
0153	0254	// œ -> ɔ
0152	0186	// Œ -> Ɔ
0076	026f	// v -> ɯ
0056	019c	// V -> Ɯ
02c7	a761	// ˇ -> ꝡ
2117	a760	// ℗ -> Ꝡ
006c	fb02	// l -> fl
004c	fb04	// L -> ffl
0338	01c9	//  -> lj
0140	01c8	// ŀ -> Lj
006a	0133	// j -> ij
004a	0132	// J -> IJ
0133	0292	// ij -> ʒ
0132	01b7	// IJ -> Ʒ
007a	01f3	// z -> dz
005a	01f2	// Z -> Dz
0259	01f1	// ə -> DZ
018f	01c7	// Ə -> LJ
0077	01bf	// w -> ƿ
0057	01f7	// W -> Ƿ
0061	00e6	// a -> æ
0041	00c6	// A -> Æ
00e6	0251	// æ -> ɑ
00c6	2c6d	// Æ -> Ɑ
0075	0223	// u -> ȣ
0055	0222	// U -> Ȣ
00f9	0265	// ù -> ɥ
00d9	a78d	// Ù -> Ɥ
0069	fb01	// i -> fi
0049	fb03	// I -> ffi
0065	025b	// e -> ɛ
0045	0190	// E -> Ɛ
20ac	1d6b	// € -> ᵫ
0074	0111	// t -> đ
0054	15ed	// T -> ᗭ
0073	00df	// s -> ß
0053	1e9e	// S -> ẞ
00df	fb05	// ß -> ſt
1e9e	fb06	// ẞ -> st
0072	0281	// r -> ʁ
006e	014b	// n -> ŋ
004e	014a	// N -> Ŋ
0334	01cc	// ̴ -> nj
0342	01cb	// ͂ -> Nj
00ba	01ca	// º -> NJ
0079	021d	// y -> ȝ
0059	021c	// Y -> Ȝ
0078	ab57	// x -> ꭗ
0058	10bf	// X -> Ⴟ
002e	2022	// . -> •
006b	0199	// k -> ƙ
004b	1e34	// K -> Ḵ
2019	2e2e	// ’ -> ⸮
003f	203d	// ? -> ‽
0071	0444	// q -> ф
0051	a01d	// Q -> ꀝ
0067	029b	// g -> ʛ
0047	13e9	// G -> Ꮹ
0068	0195	// h -> ƕ
0048	01f6	// H -> Ƕ
2020	271d	// † -> ✝
2021	2628	// ‡ -> ☨
0066	fb00	// f -> ff
005f	203e	// _ -> ‾
0020	fb03	//   -> ffi

Si quelqu’un a une idée, je suis preneur.

Merci,

Flavien

Dernière modification par Flavien21 (29/1/2016 17:52:15)


bépoète depuis mars 2015

Hors ligne

#2 22/7/2015 00:46:24

Shalena
Membres
Inscription : 12/6/2015
Messages : 16

Re : bépo AT/bópo

Bonjour,

Je ne sais si ça peut être ça qui pose problème — je n’y connais rien et n’ai personnellement jamais oser me risquer à ce genre de modifications — mais j’ai l’impression qu’il y a une ligne où la touche n’est pas définie ?

0338	01c9	//  -> lj

En tous les cas je vous souhaite bon courage pour la suite. J’avoue que je serais fort intéressée par les pilotes Windows de cette disposition lorsqu’elle sera terminée !

Hors ligne

#3 25/8/2015 11:39:17

Flavien21
Admin
Lieu : Versailles
Inscription : 12/7/2015
Messages : 142
Site Web

Re : bépo AT/bópo

C’est sûrement un bug de Windows 7, car ça fonctionne très bien sur Windows 10 sans modification.

Je vais pouvoir l’adapter en bópo et terminer les versions Mac.

À bientôt,
Flavien


bépoète depuis mars 2015

Hors ligne

#4 3/9/2015 18:13:32

Flavien21
Admin
Lieu : Versailles
Inscription : 12/7/2015
Messages : 142
Site Web

Re : bépo AT/bópo

Voilà un détail de mes modification ainsi qu’une première version des pilotes BÉPO AT pour Windows. (AltGr+Maj+À non disponible avec Windows 7).
http://www.cdc7.net/bepo/

Première version des pilotes car en faisant les images de détail je me suis rendu compte de certaines erreurs (caractères manquant ou sur une autre touche). Je vais donc corriger cela (inclus le AltGr+Maj+À) avant de faire la version BÓPO et les versions mac.

Pour ce qui est des modifications de la première page y’a surtout l’inversion entre ' et ’, L’ajout des touches mortes ̏ , ɮ (API) et ȸ (Ligatures), l’ajout de ₢ que j’ai besoin en accès direct et l’ajout de ℗, ŀ et un 3ème ͂ qui sont juste là pour créer les touches AltGr+Maj+ V, L et N pour étendre certaines touche mortes.

Sur toute les touches mortes j’ai ajouté la version souscrite de l’accentuation en normal ou AltGr ainsi que le diacritique souscrit en _.

Sur l’accent circonflexe j’ai ajouté le ŭ en v pour avoir toute la palette de l’espéranto en ^.

Pour les nouvelle touches mortes la ligne des chiffres sert à avoir soit les diacritiques (API) soit des ponctuations supplémentaire (ligatures)
Ces 2 nouvelles touche mortes sont encore améliorable, il manque encore des caractères API dont des très utilisés comme le ʃ, je m’en suis rendu compte en faisant les images.

Flavien

Dernière modification par Flavien21 (4/9/2015 10:00:53)


bépoète depuis mars 2015

Hors ligne

#5 3/9/2015 18:36:45

Shalena
Membres
Inscription : 12/6/2015
Messages : 16

Re : bépo AT/bópo

C’est vraiment du beau travail, félicitations (et merci !).

J’ai installé, tout marche nickel sur Windows 8. smile (Par contre, ça s’est installé en tant langue « Français Monaco » plutôt qu’en tant que disposition supplémentaire pour le français que j’utilisais, ça risque de m’emmêler un peu quand je dois switcher, mais bon c’est pas très grave x)

Hors ligne

#6 3/9/2015 18:50:31

Flavien21
Admin
Lieu : Versailles
Inscription : 12/7/2015
Messages : 142
Site Web

Re : bépo AT/bópo

Merci,

J’ai fais exprès de le mettre en Monaco car avec Windows 7 quand j’avais le AZERTY et le BÉPO d’installé sur Français (France) ça ajoutait un icône de clavier dans la barre des tâches que je ne voulais pas. Mais il est possible de le changer à la main (en tout cas sur Windows 7 et Windows 10).


bépoète depuis mars 2015

Hors ligne

#7 3/9/2015 18:51:41

Shalena
Membres
Inscription : 12/6/2015
Messages : 16

Re : bépo AT/bópo

Ah, ça doit aussi être possible sur 8 alors, je vais me pencher sur la question et voir si je peux régler ça ! 

Edit : en effet, c’était assez simple !

Dernière modification par Shalena (3/9/2015 19:28:53)

Hors ligne

#8 3/9/2015 22:53:07

Mimoza
Olivaw
Lieu : Terre
Inscription : 19/9/2012
Messages : 837

Re : bépo AT/bópo

J'ai rien dit au départ mais ta dénomination «bépo+» me dérange pas mal. Que tu fasse ta propre variante bépo ne me dérange absolument pas, on donne toutes les clés pour le faire même. Mais que tu dénomme ça comme une amélioration du bépo me dérange plus. Ta modification t'es propre et j'en suis heureux pour toi, elle t'apporte un plus grand confort et c'est tant mieux. Mais imagine un nouveau qui voie ce «bépo+» il va se demander si le bépo simple n'est pas obsolète.
Pour ta variante «bópo» me va très bien car clairement différente de «bépo», donc si tu pouvais repasser sur ce «+» ça serais pas mal, merci de ta compréhension.

Hors ligne

#9 4/9/2015 09:56:08

Flavien21
Admin
Lieu : Versailles
Inscription : 12/7/2015
Messages : 142
Site Web

Re : bépo AT/bópo

Pas de soucis sauf que je ne peux pas modifier mes messages pour changer l’appellation.
J’ai modifié sur le wiki.

EDIT : C’est bon c’est modifié.

Dernière modification par Flavien21 (4/9/2015 10:02:24)


bépoète depuis mars 2015

Hors ligne

#10 4/9/2015 11:08:58

Shalena
Membres
Inscription : 12/6/2015
Messages : 16

Re : bépo AT/bópo

(Re)Bonjour, je reviens avec une question ! Pour l’API, les voyelles nasales (ɑ̃, ɛ̃, ɔ̃, et œ̃) sont-elles parmi les caractères manquant qui seront ajoutés, ou sont-elles d’ores et déjà faisables avec le pilote tel quel ? (J’ai essayé à tout hasard, mais la combinaison des touches mortes pour le ~ et l’API ne semble pas fonctionner, mais peut-être m’y suis-je simplement mal prise ?)

Dernière modification par Shalena (4/9/2015 11:09:18)

Hors ligne

#11 4/9/2015 12:03:05

Flavien21
Admin
Lieu : Versailles
Inscription : 12/7/2015
Messages : 142
Site Web

Re : bépo AT/bópo

Elles sont déjà faisable.

Il faut les faire en deux fois, d’abord le caractère API seul, puis la diacritique AltGr+N,Maj+Espace.

Dernière modification par Flavien21 (4/9/2015 12:03:41)


bépoète depuis mars 2015

Hors ligne

#12 4/9/2015 12:07:06

Shalena
Membres
Inscription : 12/6/2015
Messages : 16

Re : bépo AT/bópo

Ah c’est donc bien moi qui m’y prenais mal, parfait merci beaucoup !

Tant que je suis là, à toutes fins utiles (si jamais ça peut aider pour quand vous y retoucherez), dans l’API je n’ai relevé que 2 caractères manquants, outre le ʃ que vous avez déjà signalé (du moins pour le français, qui est la seule langue pour laquelle je l’utilise) : ɲ et ə.

Et j’en profite pour vous réitérer mes félicitations et mes remerciements, votre disposition m’est très utile ! smile

Hors ligne

#13 4/9/2015 12:14:38

Flavien21
Admin
Lieu : Versailles
Inscription : 12/7/2015
Messages : 142
Site Web

Re : bépo AT/bópo

Moi j’ai noté également 3 caractères manquant mais pas les même. ʃ, ʞ et ʐ.
Le ɲ est déjà présent mais dans la touche morte crochet AltGr+?, n, et le ə est sur la page de base en AltGr+z.


bépoète depuis mars 2015

Hors ligne

#14 4/9/2015 12:16:49

Shalena
Membres
Inscription : 12/6/2015
Messages : 16

Re : bépo AT/bópo

Effectivement, je suis un gros cornichon… Et je les avais cherchés pourtant !

Hors ligne

#15 4/9/2015 13:13:15

Mimoza
Olivaw
Lieu : Terre
Inscription : 19/9/2012
Messages : 837

Re : bépo AT/bópo

Parfait je te remercie big_smile

Hors ligne

#16 5/9/2015 03:04:33

Flavien21
Admin
Lieu : Versailles
Inscription : 12/7/2015
Messages : 142
Site Web

Re : bépo AT/bópo

La version 1.1 des pilotes sont disponible voici les modifications : http://www.cdc7.net/bepo/
-Correction des problèmes dû au AltGr+Q.
-Ajout de 3 caractères API : ʃ, ʐ et ʞ
-Ajout du symbole infini en AltGr+Maj+6
-Ajout en touche morte «Ligature» des chiffres Romains au dessus de 1000, des couleurs de cartes et des lettres additionelles de l’alphabet latin (Certaines font partie d’Unicode 8.0).
-Ajout de Ұ dans les Symboles monétaires.

Et le AltGr+Maj+À ne pose plus de problèmes sur Windows 7 alors que je n’ai rien fait pour.

Les pilotes Windows pour le bópo son maintenant disponible. Il permettent la frappe du catalan et de l’occitan sans changer ses habitudes bépo ou presque.
On peux même y frapper du français mais œ et æ passent en touche morte.

Prochaine étape : les pilotes Mac.

Dernière modification par Flavien21 (5/9/2015 03:05:45)


bépoète depuis mars 2015

Hors ligne

#17 5/9/2015 10:44:30

Laurent
Membres
Inscription : 9/8/2009
Messages : 648
Site Web

Re : bépo AT/bópo

Bonjour,

Flavien21 a écrit :

La version 1.1 des pilotes sont disponible voici les modifications : http://www.cdc7.net/bepo/
[…]

Prochaine étape : les pilotes Mac.

Il manque aussi le trait d’union insécable sur le Bépo.
Si tu l’ajoutes et fais un pilote Mac, il devrait y avoir au moins un intéressé.

Hors ligne

#18 5/9/2015 17:17:34

Flavien21
Admin
Lieu : Versailles
Inscription : 12/7/2015
Messages : 142
Site Web

Re : bépo AT/bópo

Bonjour,

Je prend en note cette idée intéressante pour la prochaine mise à jour, mais je n’ai pas d’endroit logique pour le rajouter :
-Soit en Maj de la barre horizontale mais elle est sur une touche morte.
-Soit en AltGr+Maj+^ (je vois que tu le proposais dans le topic dédié donc y’a de grandes chance que ça atterrisse là)

La première version des pilotes Mac arriveront mercredi si je suis motivé (mais je ne promet rien pour cette date).


bépoète depuis mars 2015

Hors ligne

#19 9/9/2015 18:54:21

Flavien21
Admin
Lieu : Versailles
Inscription : 12/7/2015
Messages : 142
Site Web

Re : bépo AT/bópo

Le pilote mac bépoat est disponible, bópo à suivre dans quelques jours.
C’est officiellement la version 1.1 mais j’y ai glissé le trait d’union insécable en Option+Maj+^ en attendant de faire une version 1.2 avec quelques caractères en plus.

Petit détail pour le grec, en plus des lettres accentués directement disponibles, 3 touches mortes ont étés ajoutées pour suivre la logique des cascade de touche morte.
le ΄ est dispo en opt+έ ainsi qu’en maj+ς, le ¨ est en option+ς et le ΅ est en option+maj+ς.

Dernière modification par Flavien21 (9/9/2015 19:17:32)


bépoète depuis mars 2015

Hors ligne

#20 13/9/2015 10:30:04

Flavien21
Admin
Lieu : Versailles
Inscription : 12/7/2015
Messages : 142
Site Web

Re : bépo AT/bópo

Le BÓPO est maintenant disponible sur Mac.
J’ai un mini soucis sans importance cela dit : j’ai mis un icône au .bundle mais une fois le fichier téléchargé, l’icône disparait je ne comprend pas pourquoi.

Voilà maintenant tous les pilotes sont disponibles, je ne compte pas faire de pilotes linux vu que je ne possède pas ce système.
Il y aura une mis à jour d’ici quelques mois pour les finitions.
Je suis ouvert à toutes propositions.


bépoète depuis mars 2015

Hors ligne

#21 13/9/2015 10:42:06

Fork Bomb
Admin
Inscription : 12/8/2009
Messages : 201

Re : bépo AT/bópo

Flavien21 a écrit :

Le BÓPO est maintenant disponible sur Mac.
J’ai un mini soucis sans importance cela dit : j’ai mis un icône au .bundle mais une fois le fichier téléchargé, l’icône disparait je ne comprend pas pourquoi.

Voilà maintenant tous les pilotes sont disponibles, je ne compte pas faire de pilotes linux vu que je ne possède pas ce système.
Il y aura une mis à jour d’ici quelques mois pour les finitions.
Je suis ouvert à toutes propositions.

Sous Unix et dérivés, tous les fichiers et dossier dont le nom commence par « . » (le caractère "point") disparaît de l’affichage normal de l’arborescence. Mais le fichier est bien présent. On appelle ça un dossier/fichier caché.


Message tapé en Bépo avec un TypeMatrix 2030 USB smile
They see me trollin', they hatin'

Hors ligne

#22 11/1/2016 21:49:52

Flavien21
Admin
Lieu : Versailles
Inscription : 12/7/2015
Messages : 142
Site Web

Re : bépo AT/bópo

Une version 1.2 est disponible depuis quelques temps mais je n’avais jamais pris le temps de le poster ici (ni de modifier ma page avec les nouveaux caractères) : 

Voici les détails de la 1.2 :
-Ajout du trait d’union insécable en AltGr+Maj+^.
-Ajout du tilde incsrit.
-Ajout du á en accès direct pour un meilleur support de l’occitan (BÓPO uniquement).
-Ajout du support pour le bulgare et du russe en AltGr+Maj+N ce qui fait que touter les langues officielles de l’Union Européenne sont supportées.
-Ajout de ℓ à la place du ŀ en accès direct, ŀ toujours disponible pas le point suscrit et l’utilisation du point médiant · est recommendée.
-Ajout en caron de ǯ, Ǯ, ₐ, ₒ, ₑ, ₔ et ₓ.
-Ajout du la virgule inversée suscrite ◌̒ en cédille AltGr+Espace.
-Ajout en grec de certaines lettre alternatives ϵ, ϖ, ϒ et ϕ ainsi que les diacritiques seules autour du ς, ◌́, ◌̈, et ◌̈́.
-Ajout en crochet du D africain, Ɖ, ɖ.
-Ajout en ligature de ♀, ♂, ⩽, ⩾, ⅓, ⅔, ⅛, ⅜, ⅝, ⅞, de ĸ issu du groenlandais, du trait d’union conditionnel, du trait d’union, du tiret numérique et de la puce trait-d’union.

De la page http://bepo.fr/wiki/Caract%C3%A8res_pris_en_charge seul les caractères mathématique ← → ↔ ↦ ⇒ ⇔ ∂ ∏ ∑ ∆ ∇ √ ∫ ≡ ∀ ∃ ∈ ∉ ∪ ∩ ⊂ ⊃ ℝ ℂ ℚ ℕ ℤ ℍ ⊥ ‖ ∧ ∨ ⟦ ⟧ ∘ ainsi que ʼn ne sont pas pris en compte.

Je suis en train de refaire les images pour ma page, elles seront en ligne d’ici quelques semaines.


bépoète depuis mars 2015

Hors ligne

#23 5/2/2016 19:06:08

Flavien21
Admin
Lieu : Versailles
Inscription : 12/7/2015
Messages : 142
Site Web

Re : bépo AT/bópo

Je me suis motivé pour faire la version Linux, je me suis installé un Ubuntu sur une clef USB et j’ai commencer de me renseigner.
Après plein de recherches sur internet je fini par comprendre que le xkb ne gère que la couche de base et que les touches mortes font parties du locale.
Sauf que je n’arrive pas à trouver se fameux locale. J’ai cherché dans usr/share/X11/locale mais je n’ai pas de dossier fr_FR-UFT8 alors que j’utilise bien sur ce locale là (d’après la commande «locale» dans le terminal).
Même en parcourant le forum je n’ai pas trouvé de l’aide sur les touches mortes.

Autre chose l’OS rame à mort sur mon VAIO, et fonctionne quasi correctement sur mon Mac Mini. Je ne sais pas si ça viens du fait que le VAIO ne soit qu’en USB 2 ou pas. Le Live USB marchait très bien lui.


bépoète depuis mars 2015

Hors ligne

#24 5/2/2016 23:44:56

ariasuni
Admin
Lieu : France, Seine-Saint-Denis (93)
Inscription : 2/11/2012
Messages : 577
Site Web

Re : bépo AT/bópo

En fait même en français cʼest en_US.UTF-8 qui est pris en compte.


Écrit selon l’orthographe de 1990.
Ma page utilisateur, mon site web.

Hors ligne

#25 6/2/2016 01:28:32

Laurent
Membres
Inscription : 9/8/2009
Messages : 648
Site Web

Re : bépo AT/bópo

Flavien21 a écrit :

Après plein de recherches sur internet je fini par comprendre que le xkb ne gère que la couche de base et que les touches mortes font parties du locale.

En effet.

Flavien21 a écrit :

Sauf que je n’arrive pas à trouver se fameux locale. J’ai cherché dans usr/share/X11/locale mais je n’ai pas de dossier fr_FR-UFT8 alors que j’utilise bien sur ce locale là (d’après la commande «locale» dans le terminal).

Depuis le passage à UTF-8 des locales, la plupart des langues écrites en caractères latins partagent les mêmes règles de composition, qui se trouvent dans la locale américaine : /usr/share/X11/locale/en_US.UTF-8/Compose .
Ce n’est pas censé être un fichier de configuration, il peut donc être remplacé lors d’une mise à jour.
Je te conseille plutôt de ne l’utiliser que comme référence et de créer dans ton répertoire utilisateur un fichier nommé .XCompose de la forme :

# Chargement des règles de composition de la locale
include "%L"

# Règles personnelles

Attention, les fichiers Compose et .XCompose ne sont pris en compte qu’avec la méthode d’entrée standard de X (la couche graphique de Linux). Il y a des chances que ce ne soit pas celle qui soit utilisée par défaut par les nombreux logiciels basés sur la bibliothèque Gtk (ils ont réinventé la roue). Pour s’assurer qu’ils l’utilisent, il faut lancer im-config et choisir xim (acronyme de X Input Method).

Flavien21 a écrit :

Autre chose l’OS rame à mort sur mon VAIO,

Plus précisément ? Qu’est-ce qui est lent ? Le démarrage ? L’interface graphique ? Le lancement des logiciels ?
Est-ce que les logiciels fonctionnent à une vitesse normale une fois lancés ?

Flavien21 a écrit :

et fonctionne quasi correctement sur mon Mac Mini. Je ne sais pas si ça viens du fait que le VAIO ne soit qu’en USB 2 ou pas.

Si la clé est USB 3 et le Mac aussi, ses accès à la clé sont certainement plus rapides qu’avec le VAIO.

Flavien21 a écrit :

Le Live USB marchait très bien lui.

Oui, mais il est prévu pour ça. Par exemple, il utilise un pseudo-système de fichiers qui lit sur le support « live », mais écrit en mémoire.
Le plus grand inconvénient à installer sur une clé USB, n’est pas tellement la lenteur que le risque que les écritures diverses (fichiers temporaires, journaux systèmes, dates d’accès…) la rendent HS à plus ou moins court terme (suivant sa qualité).
Ça a peut-être une incidence aussi sur la rapidité…

Mieux vaut s’assurer de :
– désactiver la mise à jour des dates d’accès des fichiers (elle n’a rien d’indispensable au fonctionnement du système) en ajoutant dans le fichier /etc/fstab ,noatime au champ d’options (c’est le quatrième — l’ordre des champs est indiqué en commentaire) pour la ou les partitions correspondant à la clé USB (au moins celle qui se monte sur / — le point de montage est le deuxième champ) ;
– mettre le répertoire temporaire /tmp en mémoire (il doit y avoir une ligne du genre "tmpfs /tmp tmpfs nosuid,nodev 0 0").
Attention : toute modification de /etc/fstab est risquée, une erreur et le système ne redémarrera pas (pour réparer, il suffit de faire la modification inverse, mais accéder à un fichier sur un système HS n’est pas complètement immédiat) ; en tout cas, mieux vaut faire une copie préalable de tout fichier système qu’on s’apprête à modifier.

Si c’est l’interface graphique qui est lente, ça peut valoir le coup d’essayer Xubuntu (ou d’installer xfce4 sur le système installé sur la clé USB et de choisir ensuite Session Xfce à l’ouverture de session — sur la dernière Ubuntu, c’est l’icône de droite la moins à droite de la barre du haut).
Par ailleurs, si tu as fait l’installation depuis le Mac, le système n’a pas forcément le bon pilote graphique pour le VAIO…

Dernière modification par Laurent (6/2/2016 08:29:54)

Hors ligne

Pied de page des forums