Forum bépo

Forum des utilisateurs du bépo

Vous n'êtes pas identifié(e).

#1 7/12/2016 13:25:51

mika34
Membres
Inscription : 7/12/2016
Messages : 2

Symbole "underscore" _ avec TypeMatrix2030 sur Debian Jessie

Bonjour,

Je viens vers vous suite à un problème sur le PC du boulot sous Debian Jessie (Debian 8). J'ai récemment acquis un TypeMatrix 2030 avec un layout bepo, et j'arrive parfaitement à afficher les symboles accessibles avec une combinaison de touches incluant AltGr, que ce soit dans les tty ou le bureau Xfce :
- symbole & (AltGr + P)
- symbole | (AltGr + B)
- accolades etc...

MAIS impossible d'afficher le symbole "underscore" (symbole _) : la combinaison AltGr + espace affiche un espace...

Le problème se produit dans les tty et dans l'environnement de bureau Xfce-4.10

J'ai essayé diverses choses suggérées à droite à gauche dans les wikis et les forums, notamment :
- commande : sudo dpkg-reconfigure keyboard-configuration, et configuration du clavier en TypeMatrix 2030 USB et layout bepo fr ;
- commande : sudo sudo dpkg-reconfigure console-setup, j'ai laissé la config par défaut ("latin1 et latin7") ;
- Dans Xfce, j'ai paramétré le clavier pour prendre en compte le TypeMatrix 2030 en layout bepo. Tout le layout bepo est reconnu, mais pas le symbole underscore... grrr...

J'ai une Ubuntu 16.04 à la maison avec le même clavier et je n'ai pas ce problème.

J'ai installé Debian Jessie sur VirtualBox à la maison et configuré la machine pour l'utiliser avec le TypeMatrix 2030 en bepo : tout fonctionne correctement.

Bref, impossible d'afficher le symbole underscore sur la Debian Jessie du boulot, je n'ai aucune idée de l'origine du problème (j'ai essayé plusieurs solutions, sans succès), et je ne reproduis pas le problème sur une VM neuve avec la même distrib.

J'ajoute que ce n'est pas moi qui ai installé cette Debian mais le gars qui occupait mon poste avant mon arrivée dans l'entreprise.

Voilà, merci à ceux qui prendront le temps de m'aider, pour que je puisse enfin profiter de mon nouveau super-clavier qui reste pour l'instant dans son emballage sad

Hors ligne

#2 7/12/2016 15:43:41

Laurent
Membres
Inscription : 9/8/2009
Messages : 645
Site Web

Re : Symbole "underscore" _ avec TypeMatrix2030 sur Debian Jessie

Bonjour,

Il y a probablement un réglage quelque part qui charge une option qui redéfinit (mal) la touche Espace.
Ça se serait déjà vu ici.

Qu’affiche la commande suivante ?

setxkbmap -print

Le même problème existe-t-il aussi sur le prompt de connexion ou seulement une fois la session ouverte ?

Dans le premier cas,

sudo dpkg-reconfigure keyboard-configuration

devrait permettre de désactiver l’option fautive.
Dans le second, il faut chercher du côté des réglages clavier de l’environnement de bureau (d’ailleurs, lequel utilises-tu ?).

Dernière modification par Laurent (7/12/2016 15:48:36)

Hors ligne

#3 7/12/2016 19:31:25

mika34
Membres
Inscription : 7/12/2016
Messages : 2

Re : Symbole "underscore" _ avec TypeMatrix2030 sur Debian Jessie

Rebonjour,

Merci Laurent pour ta réponse. Ayant pas mal été occupé cet après-midi, je ne suis pas repassé par le forum, et je n'ai donc pas vu ta réponse avant ma dernière tentative de bidouille de ce soir... qui aura été la bonne ! Pour ceux qui comme moi se sont arrachés les cheveux avec le typematrix sur Jessie je vais décrire la manœuvre.

La bidouille consiste à modifier le mapping de clavier dans les fichiers système de paramétrage de xkb. Ouvrir un terminal et faire :

sudo vim /usr/share/X11/xkb/symbols/fr

Là il faut chercher la section suivante :

xkb_symbols "bepo"

Dans cette section on modifie le mapping de la section «space». On remplace donc :

key <SPCE> { [ space, space, space, space ] };

par :

key <SPCE> { [ space, space,  underscore,  underscore ] };

Et c'est tout bon ! Le symbole «underscore» est accessible dès l'écran de login, dans les tty et dans une session graphique (Xfce dans mon cas). À moi les joies des majuscules avec accents, des guillemets typographiques et autres symboles : je vais enfin pouvoir utiliser mon superbe Typematrix !

Une dernière question me taraude toutefois : cette façon de modifier un fichier système dans /usr/share est-elle assez clean ? La modification ne risque-t-elle pas d'être écrasée après une mise-à-jour de Jessie ?

Hors ligne

#4 7/12/2016 20:59:47

Laurent
Membres
Inscription : 9/8/2009
Messages : 645
Site Web

Re : Symbole "underscore" _ avec TypeMatrix2030 sur Debian Jessie

mika34 a écrit :

Ouvrir un terminal et faire :

sudo vim /usr/share/X11/xkb/symbols/fr

Là il faut chercher la section suivante :

xkb_symbols "bepo"

Dans cette section on modifie le mapping de la section «space». On remplace donc :

key <SPCE> { [ space, space, space, space ] };

Il ne devrait pas contenir ça. D’origine, il contient ça :

    key <SPCE> { [           space, nobreakspace,     underscore,          U202F ] }; // ␣ (espace insécable) _ (espace insécable fin)
mika34 a écrit :

par :

key <SPCE> { [ space, space,  underscore,  underscore ] };

Note que par rapport à la version d’origine, tu n’as pas d’espaces insécables. Cela dit, pour faire de l’informatique, ça peut éviter des erreurs pénibles.

mika34 a écrit :

Une dernière question me taraude toutefois : cette façon de modifier un fichier système dans /usr/share est-elle assez clean ?

Franchement, il semble avoir déjà été trafiqué (un peu trop fort s’il ne s’agissait que d’éviter les espaces insécables).

mika34 a écrit :

La modification ne risque-t-elle pas d'être écrasée après une mise-à-jour de Jessie ?

Pour la mise à jour des paquets en restant à la même version de la distribution, peut-être pas.
Pour la mise à jour de la version de la distribution, certainement, mais au pire, tu te retrouveras avec la version standard. Attention en attendant à ne pas prendre l’habitude de laisser traîner un peu trop ton doigt sur Maj avant de frapper une espace, sinon, une fois revenu à la version standard, tu vas te retrouver avec des espaces insécables intempestives… à moins de refaire la modification.

Hors ligne

Pied de page des forums