Forum bépo

Forum des utilisateurs du bépo

Vous n'êtes pas identifié(e).

#1 9/3/2010 22:18:59

wetneb
Membres
Inscription : 1/3/2010
Messages : 7

[linux] underscore ne fonctionne pas

Juste une petite question toute bête : comment tape-t-on un « underscore » (je ne connais pas le nom français :-/ ) ? Je ne l'ai pas trouvé dans la disposition.

Je tourne actuellement sous Ubuntu 9.10

Hors ligne

#2 9/3/2010 22:26:38

amic
Membres
Inscription : 27/11/2009
Messages : 265

Re : [linux] underscore ne fonctionne pas

AltGr + Espace

Hors ligne

#3 10/3/2010 09:41:44

wetneb
Membres
Inscription : 1/3/2010
Messages : 7

Re : [linux] underscore ne fonctionne pas

Ben justement, chez moi Alt-Gr + Espace ne donne qu'un espace classique (ou peut-être insécable). Je ne suis pas du tout un adepte de ce caractère mais c'est vrai que pour programmer c'est souvent nécessaire. Il a peut-être été ajouté récemment ?

Hors ligne

#4 10/3/2010 12:17:43

nemolivier
Modo
Lieu : Paris
Inscription : 4/8/2009
Messages : 210
Site Web

Re : [linux] underscore ne fonctionne pas

Étrange. Quel est ton OS ? Comment as-tu installé le bépo ?

Hors ligne

#5 10/3/2010 14:34:37

tazzon
Maître du Dactylotest
Inscription : 8/12/2009
Messages : 159

Re : [linux] underscore ne fonctionne pas

J'ai aussi un problème d'underscore sous PSpad. Le Alt-Gr ne donne strictement rien. Sachant que PSpad est pas mal orienté programmation le manque est assez gênant mais bon je le sais alors je fais avec…


Des outils pour apprendre, se perfectionner et se tester en dactylographie.
Dactylotest - Trydactyl - Bépodactyl

Hors ligne

#6 10/3/2010 16:19:47

Stéphane
Membres
Lieu : Annecy
Inscription : 2/9/2009
Messages : 51
Site Web

Re : [linux] underscore ne fonctionne pas

C'est normal, il y a un raccourcis à supprimer sous PSPad (je ne sais plus lequel), qui est fait par AltGr+espace. Regarder dans Option/Options du programme/Liste des raccourcis clavier.
Chez moi, ça marche bien depuis que je l'ai fait.

Hors ligne

#7 10/3/2010 16:24:18

wetneb
Membres
Inscription : 1/3/2010
Messages : 7

Re : [linux] underscore ne fonctionne pas

J'utilise Ubuntu 9.10. J'ai « installé » bépo en ajoutant à mes programmes lancés au démarrage la commande "setxkbmap fr bepo". J'imagine qu'on peut faire mieux en changeant la config de X.Org, mais cette méthode permet au moins que bépo ne soit activé que sur ma session.

Hors ligne

#8 10/3/2010 23:02:58

stqn
Membres
Inscription : 23/1/2010
Messages : 29

Re : [linux] underscore ne fonctionne pas

Je ne sais pas si ça a un rapport, mais je viens d’installer Arch Linux, et à un moment j’ai vu un message d’erreur comme quoi « RALT » avait deux trucs assignés au lieu d’un, et que le deuxième était par conséquent ignoré… Je sais, c’est pas très clair, mais sur le coup je me suis demandé si c’était pas lié au fait que « Alt-Gr » c’est la même chose que « LAlt+LCtrl » (sous Windows du moins). Du coup, un « Alt-Gr+Espace » serait interprêté comme « Ctrl+Espace » ou « Alt+Espace »…?

Je n’ai pas encore essayé d’installer le bépo sous Arch.

Hors ligne

#9 10/3/2010 23:03:08

tazzon
Maître du Dactylotest
Inscription : 8/12/2009
Messages : 159

Re : [linux] underscore ne fonctionne pas

Stéphane a écrit :

C'est normal, il y a un raccourcis à supprimer sous PSPad (je ne sais plus lequel), qui est fait par AltGr+espace. Regarder dans Option/Options du programme/Liste des raccourcis clavier.
Chez moi, ça marche bien depuis que je l'ai fait.

Merci pour l'astuce, j'y jetterai un oeil dès que possible.


Des outils pour apprendre, se perfectionner et se tester en dactylographie.
Dactylotest - Trydactyl - Bépodactyl

Hors ligne

#10 11/3/2010 10:48:45

nemolivier
Modo
Lieu : Paris
Inscription : 4/8/2009
Messages : 210
Site Web

Re : [linux] underscore ne fonctionne pas

tazzon a écrit :
Stéphane a écrit :

C'est normal, il y a un raccourcis à supprimer sous PSPad (je ne sais plus lequel), qui est fait par AltGr+espace. Regarder dans Option/Options du programme/Liste des raccourcis clavier.
Chez moi, ça marche bien depuis que je l'ai fait.

Merci pour l'astuce, j'y jetterai un oeil dès que possible.

Mais PSPad ce n’est pas un programme windows ?

Quoi qu’il en soit, ça vaut peut-être le coup de documenter ça sur le wiki… mais je ne sais pas bien dans quelle section.

Hors ligne

#11 11/3/2010 11:28:10

Stéphane
Membres
Lieu : Annecy
Inscription : 2/9/2009
Messages : 51
Site Web

Re : [linux] underscore ne fonctionne pas

nemolivier a écrit :

Mais PSPad ce n’est pas un programme windows ?

Si, uniquement Windows. C'est vrai, c'était un peu hors-sujet, ici…

Hors ligne

#12 12/3/2010 11:45:44

tazzon
Maître du Dactylotest
Inscription : 8/12/2009
Messages : 159

Re : [linux] underscore ne fonctionne pas

D'ailleurs, merci Stéphane, ça marche nickel, j'ai supprimé le raccourci gênant et plus de problème wink

C'est effectivement un programme Windows mais qui fonctionne très bien avec Wine sous Ubuntu.

Il serait peut-être bien de faire une page sur le wiki qui recense ce type de problèmes et les solutions si il y en a ?


Des outils pour apprendre, se perfectionner et se tester en dactylographie.
Dactylotest - Trydactyl - Bépodactyl

Hors ligne

#13 12/3/2010 15:19:22

joan
Membres
Lieu : Bordeaux
Inscription : 4/8/2009
Messages : 174
Site Web

Re : [linux] underscore ne fonctionne pas

Il y a la page Bugs qui recense les bugs internes et les incompatibilités avec certains logiciels.

Hors ligne

#14 12/3/2010 15:53:07

tazzon
Maître du Dactylotest
Inscription : 8/12/2009
Messages : 159

Re : [linux] underscore ne fonctionne pas

Cool, je m'en vais rajouter une ligne concernant PSPad wink


Des outils pour apprendre, se perfectionner et se tester en dactylographie.
Dactylotest - Trydactyl - Bépodactyl

Hors ligne

#15 13/3/2010 09:40:45

Mekkagodzilla
Membres
Lieu : Paris
Inscription : 11/10/2009
Messages : 54

Re : [linux] underscore ne fonctionne pas

La solution du problème initial, sous gnome :
bepo.png

Il y a un raccourci parfois mis en place sur AltGr + espace pour l’espace insécable, pratique pour les dispositions azerty et qwerty, mais génant en bépo.

Dernière modification par Mekkagodzilla (13/3/2010 09:41:19)


Linux Mint 10 / TypeMatrix USB / bépo

Hors ligne

#16 13/3/2010 23:41:25

JF
Modo
Lieu : Charleroi
Inscription : 6/12/2009
Messages : 175

Re : [linux] underscore ne fonctionne pas

wetneb a écrit :

J'utilise Ubuntu 9.10. J'ai « installé » bépo en ajoutant à mes programmes lancés au démarrage la commande "setxkbmap fr bepo". J'imagine qu'on peut faire mieux en changeant la config de X.Org, mais cette méthode permet au moins que bépo ne soit activé que sur ma session.

Si tu es sous Ubuntu, j’imagine que tu utilises Gnome.
Dans ce cas, tu peux utiliser Système > Préférences > Clavier, onglet Agencements.
Mais cette méthode et la commande setxkbmap sont incompatibles : dès qu’on a utilisé setxkbmap, les dispositions de clavier (maximum 4) activées par l’intermédiaire de cette boite de dialogue deviennent inaccessibles.

Hors ligne

Pied de page des forums