Forum bépo

Forum des utilisateurs du bépo

Vous n'êtes pas identifié(e).

#1 16/7/2010 22:08:38

Fork Bomb
Admin
Inscription : 12/8/2009
Messages : 249

[RESOLU][Linux] Bépo partout !

Début: 21h00
Bonsoir !
Dans l'optique d'un passage à Bépo, je souhaite disposer de Bépo partout dans mon OS, de l'écran de login jusqu'au shell en passant par X…
J'ai donc commencé à mettre en œuvre certains des tutos du site. Voici ce que j'ai testé jusque là:

-- ArchLinux - Passer en Bepo --

Modifier
/etc/X11/xorg.conf.d/11-keymap.conf
xkbLayout passe de "fr" a "fr,fr" et xkbVariant de "latin9" a "bepo"

Pour basculer grace aux deux SHIFT avec la LED de ScrollLock en tant que temoin
Option "xkbOptions" "grp:shifts_toggle,grp_led:scroll"

Modifier /etc/rc.conf
KEYMAP passe de "fr-latin9" a "fr-dvorak-bepo"

Ajouter les aliases dans ~/.bashrc

Ça, ça marche pas.

J'ai aussi testé ça: http://bepo.fr/wiki/X.Org_:_installation_manuelle (sauf la modification finale, le fichier était déjà bon)
Ça ne fonctionne pas non plus.

Ça aussi :
http://bepo.fr/wiki/Activation_X.Org#Ch … _avec_udev
http://bepo.fr/wiki/Activation_X.Org#Co … on_de_Xorg
Idem.
---
Toutes ces méthodes ont donné le même résultat: bépo incomplet sur SLiM (je tape «bépo». «bpo» s'affiche) et de l'azerty sous X. Le seul «truc» qui fonctionne, ce sont les aliases d'Amic smile qui me permettent de passer en Bépo.

Si vous avez besoin de voir certains fichiers, dites-le.
Fin : 22h08

Dernière modification par Fork Bomb (21/3/2011 17:15:42)


Message tapé en Bépo avec un TypeMatrix 2030 USB smile
They see me trollin', they hatin'

Hors ligne

#2 18/7/2010 00:19:11

Laurent
Membres
Inscription : 9/8/2009
Messages : 711
Site Web

Re : [RESOLU][Linux] Bépo partout !

Fork Bomb a écrit :

Modifier
/etc/X11/xorg.conf.d/11-keymap.conf
xkbLayout passe de "fr" a "fr,fr" et xkbVariant de "latin9" a "bepo"

Les layouts et les variants sont appariés.
Donc si tu mets xkbLayout à "fr,fr", il faut mettre xkbVariant par exemple à "bepo,latin9".

Fork Bomb a écrit :

Pour basculer grace aux deux SHIFT avec la LED de ScrollLock en tant que temoin
Option "xkbOptions" "grp:shifts_toggle,grp_led:scroll"

Le mieux est peut-être de ne mettre que le bepo dans un premier temps pour voir si ça marche.

Parce que tu peux avoir d’autres trucs qui prennent le pas sur le réglage fait ici.
Par exemple un fichier spécifique à ta distribution, le gestionnaire de connexion (surtout si c’est gdm), ton environnement (surtout si c’est Gnome)…

Hors ligne

#3 21/7/2010 17:53:32

Fork Bomb
Admin
Inscription : 12/8/2009
Messages : 249

Re : [RESOLU][Linux] Bépo partout !

Laurent a écrit :
Fork Bomb a écrit :

Pour basculer grace aux deux SHIFT avec la LED de ScrollLock en tant que temoin
Option "xkbOptions" "grp:shifts_toggle,grp_led:scroll"

Le mieux est peut-être de ne mettre que le bepo dans un premier temps pour voir si ça marche.

C’est ce que j’ai fini par faire en définitive.

Laurent a écrit :

Parce que tu peux avoir d’autres trucs qui prennent le pas sur le réglage fait ici.
Par exemple un fichier spécifique à ta distribution, le gestionnaire de connexion (surtout si c’est gdm), ton environnement (surtout si c’est Gnome)…

Mon gestionnaire de connexion est SLiM et mon bureau est XFCE.


Message tapé en Bépo avec un TypeMatrix 2030 USB smile
They see me trollin', they hatin'

Hors ligne

#4 22/7/2010 18:27:12

Fork Bomb
Admin
Inscription : 12/8/2009
Messages : 249

Re : [RESOLU][Linux] Bépo partout !

Mes problèmes sont presque tous résolus.
Deux demeurent cependant :
1) avec Slim, tous les caractères ne s’affichent pas.
Si je tape « bépo », seul « bpo » s’affiche hmm

2) Quand j’arrive sur Slim justement, le clavier n’est pas actif. Il faut que je le débranche/rebranche pour pouvoir taper. Dur hmm
Mes manipulations :
- effacement de la section concernant le clavier dans /etc/X11/xorg.conf
- effacement du fichier /etc/X11/xorg.conf.d/*-keymap.conf
- création de la règle udev et du fichier adéquat en suivant les §2.3.1 et 2.3.2 Activation X.org

Si vous avez besoin d’informations complémentaires, faites-le moi savoir smile


Message tapé en Bépo avec un TypeMatrix 2030 USB smile
They see me trollin', they hatin'

Hors ligne

#5 4/8/2010 08:36:48

Laurent
Membres
Inscription : 9/8/2009
Messages : 711
Site Web

Re : [RESOLU][Linux] Bépo partout !

Ça fait un certain temps que je pensais essayer Arch Linux.
Cette fois, je m’y suis mis.

Fork Bomb a écrit :

Mes problèmes sont presque tous résolus.
Deux demeurent cependant :
1) avec Slim, tous les caractères ne s’affichent pas.
Si je tape « bépo », seul « bpo » s’affiche hmm

D’un autre côté, utiliser des caractères dont l’encodage n’est pas le même suivant la locale dans les noms d’utilisateurs ne serait pas très pertinent, donc de là à ce que ce soit fait exprès…

Fork Bomb a écrit :

2) Quand j’arrive sur Slim justement, le clavier n’est pas actif. Il faut que je le débranche/rebranche pour pouvoir taper.

Je n’ai pas ce problème.
Heureusement : c’est sur un portable !

Fork Bomb a écrit :

Mes manipulations :
- effacement de la section concernant le clavier dans /etc/X11/xorg.conf
- effacement du fichier /etc/X11/xorg.conf.d/*-keymap.conf
- création de la règle udev et du fichier adéquat en suivant les §2.3.1 et 2.3.2 Activation X.org

Je n’ai pas de /etc/X11/xorg.conf.
Je n’ai pas trafiqué udev.
J’ai juste ajouté les options "XkbLayout" et "XkbVariant" à la section concernant le clavier du fichier /etc/X11/xorg.conf.d/10-evdev.conf existant :

Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "XkbLayout" "fr"
        Option "XkbVariant" "beop"
        Option "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

(à part l’ajout de ma disposition personnelle dans /usr/share/X11/xkb/symbols/fr et dans /usr/share/X11/xkb/rules/evdev.xml, mais pour "bepo", ce ne serait pas nécessaire, il y est déjà).

Hors ligne

#6 21/3/2011 17:15:02

Fork Bomb
Admin
Inscription : 12/8/2009
Messages : 249

Re : [RESOLU][Linux] Bépo partout !

Je remonte ce fil et le considère comme résolu.
Le problème venait de la règle UDEV. Il ne fallait pas l'utiliser. Le simple fait d'avoir enlever cette règle et le fichier associé à suffit à récupérer l'activation du clavier (en Bépo) au démarrage…
Merci donc à Laurent de s'être cassé les dents sur mon problème.


Message tapé en Bépo avec un TypeMatrix 2030 USB smile
They see me trollin', they hatin'

Hors ligne

Pied de page des forums