Forum bépo

Forum des utilisateurs du bépo

Vous n'êtes pas identifié(e).

#1 17/11/2017 00:15:00

Or2v
Membres
Inscription : 16/11/2017
Messages : 5

Linux incohérence Wayland XWayland pr les raccourcis clavier (Ubuntu)

Bonjour,
Je viens d'ouvrir mon compte pour ce problème…
J'utilise Bépo depuis environ un an et ne peux plus m'en passer. Je peux enfin frapper entièrement “en aveugle”, réellement, sans regarder le clavier, ce que je n'étais jamais parvenu à faire en Azerty, en plus de 20 ans ! La disposition des touches en Bépo est réellement logique et naturelle !
Mon ordi est sous Linux-Ubuntu, et je viens de le passer de la version 17.04 à sa dernière version 17.10. et voilà que j'ai un problème…
Dans sa version normale, avec Gnome 3 et le nouveau protocole d'affichage des fenêtres Wayland, les raccourcis clavier (Ctrl-c, Ctrl-x, Ctrl-v, etc.) fonctionnent normalement pour les applications dont les fenêtres sont affichées avec le protocole XWayland (qui applique le protocole ancien d'Xorg), mais pour les fenêtres affichées avec le nouveau protocole Wayland, ces raccourcis clavier correspondent à la disposition du clavier Azerty. Cela fait que je dois jongler entre des deux types de raccourcis quand je passe, par exemple d'une fenêtre de Firefox (v. 56, XWayland) à une fenêtre de l'éditeur de texte Gedit (Wayland).
Il n'y a pas cette incohérence quand j'utilise Ubuntu avec l'afficheur Xorg, ou avec Unity. Dans ce cas, dans toutes les fenêtres, les raccourcis correspondent à la disposition Bépo. Je veux bien qu'on ai une disposition Bépo avec des raccourcis selon la disposition Azerty, mais que l'on puisse la choisir, ou pas, comme une disposition alternative, pour la totalité des applications, mais pas qu'elle soit imposée pour seulement une partie des applications. Ça fait trop désordre !
(J'ai présenté mon problème également sur le forum ubuntu-fr.org (dans la section Gnome 3) il y a 2 jours, mais pas de solution pour l'instant.)

Hors ligne

#2 17/11/2017 01:13:05

Mimoza
Olivaw
Lieu : Terre
Inscription : 19/9/2012
Messages : 971

Re : Linux incohérence Wayland XWayland pr les raccourcis clavier (Ubuntu)

Salut Or2v,
Je t'ai passé membre pour que tu puisse profiter pleinement de forum et entre autre inclure des liens dans tes messages.
Je pense que ton sujet sur le forum Ubuntu est celui là : https://forum.ubuntu-fr.org/viewtopic.php?id=2017639

Concernant ton soucis c'est en effet très embêtant (pour rester poli). Tu n'es pas le seul a utiliser du Linux ici, mais je pense l'un des rare a être passé à wayland … du coup je n'ai pas entendu parler d'un tel soucis pour le moment. Il faudrait se plonger dans la configuration de wayland pour comprendre de quoi il retourne.
Juste un petit truc, dans ton message sur l'autre forum tu parle de «Bépo Latin 9» … par hasard ça ne redéfinirais pas seulement les touches de l'alphabet ? As-tu d'autre option possible ? «Bépo» tout court serait mieux je pense.

Hors ligne

#3 17/11/2017 02:39:46

Or2v
Membres
Inscription : 16/11/2017
Messages : 5

Re : Linux incohérence Wayland XWayland pr les raccourcis clavier (Ubuntu)

Merci Mimoza pour l'accueil !
C'est bien le bon lien pour ma publication sur le forum de ubuntu-fr.org.
Apparemment Wayland utilise la même extension de configuration du clavier que Xorg, Xkb, dont il me semble avoir trouvé les fichiers de configuration sur /usr/share/X11/xkb/
Mon Ubuntu 17.10 me propose deux claviers Bépo: “Bépo” et “Bépo (Latin-9 uniquement)” qui semble n'être qu'une version avec légèrement moins de caractères.
Par exemple pour la touche à gauche du 1 du clavier (marquée “²” en Azerty), j'ai, en “Bépo” les 4 caractères: $#–¶, mais en “Bépo (Latin-9 uniquement)”, j'ai $#$¶.
Le tiret “–” obtenu avec AltGr est remplacé par le même “$” que celui de la frappe directe.
Je n'ai pas d'autre choix de clavier Bépo que ces deux là (en particulier pas une option qui prévoirait explicitement des raccourcis claviers selon la disposition Azerty, ce que je ne recherche d'ailleurs pas particulièrement.)
Je ne sais pas où trouver la définition des raccourcis claviers (de type Ctrl-c, Ctrl-x, Ctrl-v), dans les fichiers de configuration de Xkb…
Avec Ubuntu 17.10 je peux toujours me loguer en Ubuntu-Gnome-Xorg ou encore Ubuntu-Unity (que je préfère encore, d'ailleurs, j'étais bien habitué), et alors je n'ai plus du tout ce problème smile
Complément: Ubuntu vient de me mettre à jour Firefox dans la version 57, et cette toute dernière version utilise toujours XWayland et non pas Wayland…

Hors ligne

#4 17/11/2017 08:32:45

Laurent
Membres
Inscription : 9/8/2009
Messages : 668
Site Web

Re : Linux incohérence Wayland XWayland pr les raccourcis clavier (Ubuntu)

Bonjour et bienvenue,

Or2v a écrit :

Mon Ubuntu 17.10 me propose deux claviers Bépo: “Bépo” et “Bépo (Latin-9 uniquement)” qui semble n'être qu'une version avec légèrement moins de caractères.

Effectivement. C’est la version limitée au jeu de caractères huit bits qui était utilisé pour le français (ISO Latin-9) avant le passage à Unicode (et plus précisément UTF-8).

Or2v a écrit :

Je ne sais pas où trouver la définition des raccourcis claviers (de type Ctrl-c, Ctrl-x, Ctrl-v), dans les fichiers de configuration de Xkb…

Dans Xkb tel qu’utilisé par X.org, il n’y en a pas, c’est « automatique » (déduit d’après le caractère qui serait produit sans Ctrl).

Des pistes pour affiner le diagnostic :
– Quand tu fais Ctrl+a dans Gedit, est-ce que ça te sélectionne tout le texte, ou est-ce que ça ferme l’éditeur ? C’est pour savoir si Wayland est mal configuré (Azerty) ou ne considère aucune disposition pour les combinaisons avec Ctrl (Qwerty US).
– Essayer une application KDE qui fonctionne avec Wayland (KDE supporte Wayland ; après il faut voir si c’est le cas tel qu’il est empaqueté pour Ubuntu), pour voir si le problème est spécifique aux applications Gtk (ou Gnome).
– Essayer une Fedora (j’espère qu’elle peut utiliser Wayland en live ; après tout, elle le pousse depuis plus longtemps qu’Ubuntu) pour voir si c’est un problème général avec Wayland ou si c’est spécifique à Ubuntu (auquel cas il y aurait plus d’espoir d’arriver à le corriger soi-même).

Or2v a écrit :

Avec Ubuntu 17.10 je peux toujours me loguer en Ubuntu-Gnome-Xorg ou encore Ubuntu-Unity (que je préfère encore, d'ailleurs, j'étais bien habitué), et alors je n'ai plus du tout ce problème smile

Profite bien d’Unity, il va disparaître dans la prochaine version d’Ubuntu (comme Mir, une alternative à Wayland développée par Ubuntu, il est abandonné par celui-ci). Bon, il devrait y avoir une sorte de thème Gnome 3 se rapprochant d’Unity.

Hors ligne

#5 17/11/2017 11:35:51

Or2v
Membres
Inscription : 16/11/2017
Messages : 5

Re : Linux incohérence Wayland XWayland pr les raccourcis clavier (Ubuntu)

Bonjour Laurent,
Merci pour tes suggestions.

Laurent a écrit :

Dans Xkb tel qu’utilisé par X.org, il n’y en a pas, c’est « automatique » (déduit d’après le caractère qui serait produit sans Ctrl).

Merci pour cette information précieuse. On s'attend donc à ce que Wayland fasse de même. D'ailleurs, pour l'application Terminal dont les fenêtres sont lancées avec Wayland, qui ouvre le Bash, quand je fais Ctrl+c en cours d'exécution d'une commande, celle-ci est interrompue, comme on doit s'y attendre. Par contre, pour faire un copie d'une sélection faite à la souris (normalement Ctrl+Maj+c), il faut que je fasse Ctrl+Maj+x (le c de Azerty ou Qwerty). Et quand je fais Ctrl+Maj+a (le a du Qwerty, et le q de l'Azerty), c'est compris comme pour le clavier Azerty, comme Ctrl+Maj+q, la fenêtre se ferme…

Laurent a écrit :

Des pistes pour affiner le diagnostic :
– Quand tu fais Ctrl+a dans Gedit, est-ce que ça te sélectionne tout le texte, ou est-ce que ça ferme l’éditeur ? C’est pour savoir si Wayland est mal configuré (Azerty) ou ne considère aucune disposition pour les combinaisons avec Ctrl (Qwerty US).

Ben oui, le q du clavier Azerty. C'est bien interprété comme Ctrl+q, cela fait quitter l'application. Ça m'a fait penser à changer le paramétrage du clavier pour mon login, de Azerty à Bépo, en imaginant que cet paramétrage était retenu dans la session. Mais ça n'a rien changé au problème…

Laurent a écrit :

– Essayer une application KDE qui fonctionne avec Wayland (KDE supporte Wayland ; après il faut voir si c’est le cas tel qu’il est empaqueté pour Ubuntu), pour voir si le problème est spécifique aux applications Gtk (ou Gnome).
– Essayer une Fedora (j’espère qu’elle peut utiliser Wayland en live ; après tout, elle le pousse depuis plus longtemps qu’Ubuntu) pour voir si c’est un problème général avec Wayland ou si c’est spécifique à Ubuntu (auquel cas il y aurait plus d’espoir d’arriver à le corriger soi-même).

J'essaierai, mais plus tard…

Laurent a écrit :

Profite bien d’Unity, il va disparaître dans la prochaine version d’Ubuntu (comme Mir, une alternative à Wayland développée par Ubuntu, il est abandonné par celui-ci). Bon, il devrait y avoir une sorte de thème Gnome 3 se rapprochant d’Unity.

Cette sorte de thème Gnome 3 est déjà ce que propose Ubuntu 17.10 par défaut, mais je trouve que c'est moins fluide, moins agréable, la barre de menu unique de Unity, le “radar” pour rechercher dans les commandes du menu, ont disparu, dommage ! (Il propose aussi en choix complémentaire Gnome 3 pur, et encore Unity…) À suivre pour mon affaire. MERCI beaucoup pour les suggestions.

Hors ligne

#6 22/11/2017 09:16:41

Or2v
Membres
Inscription : 16/11/2017
Messages : 5

Re : Linux incohérence Wayland XWayland pr les raccourcis clavier (Ubuntu)

Laurent a écrit :

– Essayer une application KDE qui fonctionne avec Wayland (KDE supporte Wayland ; après il faut voir si c’est le cas tel qu’il est empaqueté pour Ubuntu), pour voir si le problème est spécifique aux applications Gtk (ou Gnome).
– Essayer une Fedora (j’espère qu’elle peut utiliser Wayland en live ; après tout, elle le pousse depuis plus longtemps qu’Ubuntu) pour voir si c’est un problème général avec Wayland ou si c’est spécifique à Ubuntu (auquel cas il y aurait plus d’espoir d’arriver à le corriger soi-même).

J'ai essayé tout simplement le live CD Ubuntu 17.10 (même version que celle installée sur mon ordi). Et là, tout est impeccable ! Donc le problème n'est même pas dans ma distribution, mais dans mon installation qui était une mise-à-jour depuis la 17.04.

Pour limiter le problème, j'ai mis Bépo en disposition principale de clavier (utilisée 95% du temps), et Azerty, seul, en disposition secondaire. C'est maintenant Bépo qui impose ses raccourcis clavier à Azerty (Ctrl+c, etc.) : un moindre mal…

Mais je reste curieux de tout information pouvant m'aider à résoudre ce problème (première disposition de clavier qui impose ses raccourcis aux dispositions secondaires, uniquement pour les fenêtres Wayland et pas pour les fenêtres XWayland,) sans avoir à tout réinstaller…

Hors ligne

#7 25/11/2017 01:48:49

Laurent
Membres
Inscription : 9/8/2009
Messages : 668
Site Web

Re : Linux incohérence Wayland XWayland pr les raccourcis clavier (Ubuntu)

Or2v a écrit :

Donc le problème n'est même pas dans ma distribution, mais dans mon installation qui était une mise-à-jour depuis la 17.04.

On ne peut pas écarter non plus à priori la configuration dans le répertoire utilisateur, qui date aussi de la distribution précédente.
Mais pour ça, tu pourrais essayer en créant un nouvel utilisateur de voir s’il présente le même problème ou pas.

Or2v a écrit :

Mais je reste curieux de tout information pouvant m'aider à résoudre ce problème (première disposition de clavier qui impose ses raccourcis aux dispositions secondaires, uniquement pour les fenêtres Wayland et pas pour les fenêtres XWayland,) sans avoir à tout réinstaller…

Pour ma part, je prévois des partitions pour deux distributions. Ça me permet de préparer une nouvelle distribution tranquillement si je m’apprête à en changer, mais aussi de faire des tests si besoin. Par exemple, ça pourrait permettre de comparer une installation fraîche à mon système courant si celui-ci avait un comportement anormal.

Hors ligne

#8 25/11/2017 19:03:51

Or2v
Membres
Inscription : 16/11/2017
Messages : 5

Re : Linux incohérence Wayland XWayland pr les raccourcis clavier (Ubuntu)

Laurent a écrit :

On ne peut pas écarter non plus à priori la configuration dans le répertoire utilisateur, qui date aussi de la distribution précédente.
Mais pour ça, tu pourrais essayer en créant un nouvel utilisateur de voir s’il présente le même problème ou pas.

Merci une fois de plus Laurent ! Voilà une excellente suggestion ! J'ai donc créé un 2e compte, et ouvert, sur ce compte, Gedit. Et bien, le phénomène est exactement le même. J'ai interverti l'ordre des deux configurations de clavier par l'outil de paramétrage de système, et alors, sans même qu'il faille redémarrer la session, c'est la nouvelle mise en premier qui impose ses raccourcis clavier à l'autre.

Laurent a écrit :

Pour ma part, je prévois des partitions pour deux distributions. Ça me permet de préparer une nouvelle distribution tranquillement si je m’apprête à en changer, mais aussi de faire des tests si besoin. Par exemple, ça pourrait permettre de comparer une installation fraîche à mon système courant si celui-ci avait un comportement anormal.

Sur mon ordi, rien de tout ça… C'est un dual boot W7/Linux. Et pour Linux, je n'ai, en plus du Swap, qu'une seule partition, sur laquelle tout est mélangé (et en particulier le /home avec tout le reste…) Je retiens l'exemple pour plus tard !

Hors ligne

#9 26/11/2017 20:27:57

Laurent
Membres
Inscription : 9/8/2009
Messages : 668
Site Web

Re : Linux incohérence Wayland XWayland pr les raccourcis clavier (Ubuntu)

Des fois que ce soit lié à la configuration système, tu peux peut-être monter ton système depuis le live CD et faire un diff -rq entre les répertoires etc du système live et du tien. Ça va te donner un bon nombre de faux positifs (nom d’hôte…), mais dans le tas, il y aura peut-être des fichiers plus intéressants à regarder de plus près.

Hors ligne

#10 11/7/2018 11:52:45

dwd2b
Membres
Inscription : 10/7/2018
Messages : 5

Re : Linux incohérence Wayland XWayland pr les raccourcis clavier (Ubuntu)

Bonjour

Petit "up". Nous sommes maintenant nombreux j'imagine à utiliser Wayland et le problème est toujours là ! Et je n'ai toujours aucune solution pour changer cette disposition qui m'insupporte !
Y a-t'il un moyen simple de retrouver la "vraie" disposition BÉPO ?

Hors ligne

#11 13/7/2018 23:05:57

Mimoza
Olivaw
Lieu : Terre
Inscription : 19/9/2012
Messages : 971

Re : Linux incohérence Wayland XWayland pr les raccourcis clavier (Ubuntu)

Salut,
Si tu regardes le dernier message sur le forum Ubuntu (https://forum.ubuntu-fr.org/viewtopic.p … #p21829726) apparement le soucis viens de l'ancienneté de l'installation, sur un live-cd ça semble fonctionner correctement.

Hors ligne

#12 17/7/2018 09:56:14

dwd2b
Membres
Inscription : 10/7/2018
Messages : 5

Re : Linux incohérence Wayland XWayland pr les raccourcis clavier (Ubuntu)

Merci !
un peu dommage de devoir tout réinstaller juste pour un problème de clavier :-(

Hors ligne

#13 17/7/2018 17:57:14

Fork Bomb
Admin
Inscription : 12/8/2009
Messages : 212

Re : Linux incohérence Wayland XWayland pr les raccourcis clavier (Ubuntu)

dwd2b a écrit :

Merci !
un peu dommage de devoir tout réinstaller juste pour un problème de clavier :-(

do-release-upgrade ne fonctionne pas ?


Message tapé en Bépo avec un TypeMatrix 2030 USB smile
They see me trollin', they hatin'

Hors ligne

#14 18/7/2018 16:02:36

dwd2b
Membres
Inscription : 10/7/2018
Messages : 5

Re : Linux incohérence Wayland XWayland pr les raccourcis clavier (Ubuntu)

Ha si, en soi ça fonctionne très bien ! Mais mon problème reste entier ... le mappage du client est toujours mauvais.
Idem après la réinstallation également, alors que dans le liveCD c'est nickel.

J'ai donc réinstallé ubuntu, perdu mes imprimantes réseaux, et quelques applis, tout ça pour un clavier bépo toujours aussi dysfonctionnel !

Hors ligne

#15 18/7/2018 17:30:07

Mimoza
Olivaw
Lieu : Terre
Inscription : 19/9/2012
Messages : 971

Re : Linux incohérence Wayland XWayland pr les raccourcis clavier (Ubuntu)

Bizarre … là le soucis étant plus lié à l'OS je te conseil de relancer le sujet sur le forum concerné.
Sinon c'est ouvrir un bug pour l'OS.

Hors ligne

#16 20/7/2018 07:13:57

Laurent
Membres
Inscription : 9/8/2009
Messages : 668
Site Web

Re : Linux incohérence Wayland XWayland pr les raccourcis clavier (Ubuntu)

Bonjour,

dwd2b a écrit :

J'ai donc réinstallé ubuntu, perdu mes imprimantes réseaux, et quelques applis, tout ça pour un clavier bépo toujours aussi dysfonctionnel !

D’après ce que je vois passer par ailleurs, Wayland n’est pas encore tout à fait mûr.
Qui plus est, même en version X, Gnome a un don pour foirer les configurations clavier : l’interface de paramétrage du clavier a tendance à faire des trucs qu’on ne lui demande pas (genre ajouter la disposition Qwerty US, au mieux en plus de celle(s) demandée(s)) et pas toujours ce qu’on lui demande. Et ça, c’est quand c’est prévu. Par exemple, il y en a qui se plaignent qu’il ne soit pas possible de changer de disposition clavier à partir de l’interface de connexion, alors que c’est possible avec LightDM, qu’Ubuntu utilisait précédemment (et qui est toujours utilisée par certaines variantes comme Xubuntu).

Comme je n’aime pas l’interface de Gnome 3, je m’épargne des soucis en utilisant un environnement graphique moins à la pointe (donc qui n’utilise pas Wayland), comme Xfce. Il y a moyen d’ajouter Xfce ou un autre environnement graphique sur un système existant, il faut juste trouver le bon paquet, celui qui déclenche l’installation de tous les autres paquets utiles (pour Xfce, c’est peut-être xfce4, de mémoire ; je ne peux pas vérifier en cet instant, je ne suis pas sur Ubuntu).

Cela dit, même si tu tiens à Gnome 3, il y a peut-être quand même moyen de lancer un environnement Gnome 3 non Wayland.
Si Wayland n’apporte aucune fonctionnalité qui te manque avec X.org et que ça te cause des difficultés, autant attendre encore pour l’utiliser…

Hors ligne

#17 20/7/2018 11:42:58

dwd2b
Membres
Inscription : 10/7/2018
Messages : 5

Re : Linux incohérence Wayland XWayland pr les raccourcis clavier (Ubuntu)

Merci de ta réponse ! Je tiens effectivement à Gnome 3, contre lequel j'ai longtemps pesté, mais je suis habitué maintenant !
J'ai résolu le problème avec dpkg-reconfigure keyboard-configuration en console... mais je dois le refaire à chaque redémarrage

Hors ligne

#18 9/8/2018 18:30:37

damien thiriet
Membres
Lieu : Varsovie
Inscription : 2/9/2010
Messages : 140
Site Web

Re : Linux incohérence Wayland XWayland pr les raccourcis clavier (Ubuntu)

Je déterre un peu le sujet, mais s’il y a une manipulation à refaire à chaque démarrage, place là dans ton .xinitrc ou autre fichier de démarrage utilisé par gnome3.


TM 2030, bépo depuis 2010
Open BSD - pdksh - ratpoison + dmenu + tmux + st - Vim - zathura - xombrero - sxiv
ma page du wiki

Hors ligne

#19 29/8/2018 17:51:05

dwd2b
Membres
Inscription : 10/7/2018
Messages : 5

Re : Linux incohérence Wayland XWayland pr les raccourcis clavier (Ubuntu)

J'y ai pensé, mais pas possible : dpkg-reconfigure keyboard-configuration demande de valider des choix en console, il est interactif

Hors ligne

#20 30/8/2018 10:56:01

Laurent
Membres
Inscription : 9/8/2009
Messages : 668
Site Web

Re : Linux incohérence Wayland XWayland pr les raccourcis clavier (Ubuntu)

dwd2b a écrit :

J'y ai pensé, mais pas possible : dpkg-reconfigure keyboard-configuration demande de valider des choix en console, il est interactif

D’un autre côté, un environnement décent (Xfce…) permettrait au moins de conserver la configuration clavier du système (pas Gnome 3, apparemment) et il ne devrait plus y avoir de souci (le système reprend au démarrage les réglages que tu as configuré avec dpkg-reconfigure keyboard-configuration).

Si j’étais à ta place, je tenterais de neutraliser le réglage sabotage du clavier de Gnome (si tu es le seul utilisateur de ton PC ou que les autres utilisent le Bépo aussi).

Pour ça, je peux te suggérer un modus operandi que je n’ai pas essayé (j’ai juste jeté un coup d’œil sur une Ubuntu live ; il n’est pas question que j’installe Gnome sur mon PC).

Tout d’abord, passer sur une console texte (parce que si ça met la zone, ce sera plus pratique pour remettre comme avant), avec par exemple Ctrl+Alt+F2.

sudo dpkg-divert --divert /usr/lib/gnome-settings-daemon/gsd-keyboard.orig --rename /usr/lib/gnome-settings-daemon/gsd-keyboard
sudo ln -s /bin/true /usr/lib/gnome-settings-daemon/gsd-keyboard

Repasser sur la console graphique (classiquement avec Ctrl+Alt+F7 — sur d’autres distributions, c’est Ctrl+Alt+F1), fermer la session et en rouvrir une.

S’il est impossible d’ouvrir la session, repasser sur la console texte et remettre les choses dans l’état d’origine avec :

sudo rm /usr/lib/gnome-settings-daemon/gsd-keyboard
sudo dpkg-divert --rename --remove /usr/lib/gnome-settings-daemon/gsd-keyboard

Sinon, Gnome ne devrait plus cochonner les réglages clavier.

Dernière modification par Laurent (30/8/2018 11:29:52)

Hors ligne

Pied de page des forums