Forum bépo

Forum des utilisateurs du bépo

Vous n'êtes pas identifié(e).

#1 15/1/2022 15:42:26

BobGall
Nouveaux membres
Inscription : 15/1/2022
Messages : 3

Problème avec Alt-Gr+espace pour obtenir le caractère "underscore".

Après configuration de bépo à l'installation de Debian, Alt-Gr + Espace ne fonctionne pas pour obtenir le tiret bas (underscore).
Après de nombreuses recherches je n'ai pas trouvé de solution.

Hors ligne

#2 15/1/2022 23:59:07

Mimoza
Admin
Lieu : Terre
Inscription : 19/9/2012
Messages : 1 218

Re : Problème avec Alt-Gr+espace pour obtenir le caractère "underscore".

Salut BobGall,
As-tu regardé du coté des raccourcis clavier de ton environnement graphique ? D’ailleurs le quel utilise tu ?

Hors ligne

#3 16/1/2022 11:40:00

BobGall
Nouveaux membres
Inscription : 15/1/2022
Messages : 3

Re : Problème avec Alt-Gr+espace pour obtenir le caractère "underscore".

KDE Plasma

Hors ligne

#4 17/1/2022 13:33:14

BobGall
Nouveaux membres
Inscription : 15/1/2022
Messages : 3

Re : Problème avec Alt-Gr+espace pour obtenir le caractère "underscore".

J'ai résolu mon problème :

Dans le fichier

 /usr/share/X11/xkb/symbols/fr

j'ai remplacé dans la session :

xkb_symbols "bepo_latin9"

j'ai remplacé le texte suivant :

key <SPCE> { [           space,  nobreakspace,    underscore,   nobreakspace ] }

par

key <SPCE> { [           space,        space,    underscore,     underscore ] }

Hors ligne

#5 21/2/2022 12:25:19

boumbh
Membres
Inscription : 7/9/2012
Messages : 12

Re : Problème avec Alt-Gr+espace pour obtenir le caractère "underscore".

Bonjour,

J'ai eu un problème similaire sous Linux Mint 20.3 : pas d'underscore dans le Terminal Gnome, dans Firefox ou dans tout autre application de l'environnement graphique...

Par contre j'avais bien l'underscore en mode text (Ctrl-Shift-F3 ; note : pour revenir à l'interface graphique il faut faire Ctrl-Shift-F7 wink ).

Ça me faisait peur d'aller trifouiller dans les fichiers de conf comme suggéré ici alors j'ai cherché une autre solution.

J'ai résolu mon problème en reconfigurant le clavier comme suggéré dans le post de Laurent de ce vieux thread.

sudo dpkg-reconfigure keyboard-configuration

J'ai pas mal tatonné, et j'ai enfin compris que pour que la nouvelle configuration fonctionne il fallait se déconnecter (fermer la session Mint) et se reconnecter.

Du coup, je ne sais pas ce qui n'allait pas dans ma conf initiale, mais voici mon keymap actuel qui marche... (si ça peut aider quelqu'un à ne pas trop se prendre la tête avec le keyboard-configuration big_smile)

$ setxkbmap -print
xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(azerty)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+fr(bepo_latin9)+inet(evdev)+group(win_space_toggle)+terminate(ctrl_alt_bksp)"	};
	xkb_geometry  { include "typematrix(tm2030USB)"	};
};

Hors ligne

#6 21/2/2022 16:11:45

damien thiriet
Membres
Lieu : Varsovie
Inscription : 2/9/2010
Messages : 157
Site Web

Re : Problème avec Alt-Gr+espace pour obtenir le caractère "underscore".

Bonjour,

Je réagis fort tard à ton post du 17 janvier: il est curieux que cela ait résolu ton problème car tu as modifié les combinaisons correspondant à SHIFT+espace et SHIFT+AltGr+espace…


TM 2030, bépo depuis 2010
Open BSD - pdksh - ratpoison + dmenu + tmux + st - Vim - zathura ou mupdf - imv ou sxiv - keynav
ma page du wiki

Hors ligne

Pied de page des forums