Forum bépo

Forum des utilisateurs du bépo

Vous n'êtes pas identifié(e).

#1 31/3/2011 10:21:46

jemini
Membres
Inscription : 31/3/2011
Messages : 4

Problème clavier bépo touche TLDE (numbersign/dollars) [RESOLU]

bonjour,

j'utilise un clavier bépo TypeMatrix 2030 dont je suis entièrement satisfait smile. Je l'utilise sous ubuntu 10.04.

J'ai donc configuré système->préférences->clavier en bépo et tout fonctionne parfaitement excepté la touche TLDE qui renvoie le signe inférieur (<) au lieu des signes numbersign/dollars (#/$).
Quand je regarde dans le fichier /usr/share/X11/xkb/symbols/fr , la touche TLDE semble cependant bien configurée :

// /usr/share/X11/xkb/symbols/fr

partial alphanumeric_keys
xkb_symbols "bepo" {

    include "level3(ralt_switch)"
    include "keypad(oss)"

    name[Group1]= "France - Bepo, ergonomic, Dvorak way";

    // First row
    key <TLDE> { [          dollar,   numbersign,        endash,       paragraph ] }; // $ # – ¶

De plus, quand je lance la commande setxkbmap fr bepo, je retrouve les signes numbersign/dollars sous TLDE.
J'ai donc tenté d'exécuter cette commande à l'ouverture de la session gnome (Système->Préférences->Applications au démarrage) mais sans résultat.

Merci pour votre aide.

J.

Dernière modification par jemini (31/3/2011 14:45:05)

Hors ligne

#2 31/3/2011 10:27:15

Fork Bomb
Admin
Inscription : 12/8/2009
Messages : 249

Re : Problème clavier bépo touche TLDE (numbersign/dollars) [RESOLU]


Message tapé en Bépo avec un TypeMatrix 2030 USB smile
They see me trollin', they hatin'

Hors ligne

#3 31/3/2011 10:33:31

Calmacil
Membres
Inscription : 18/2/2011
Messages : 12

Re : Problème clavier bépo touche TLDE (numbersign/dollars) [RESOLU]

Bonjour,

J'ai eu des problèmes similaires sous Ubuntu 10.04 et 10.10 avec KDE. En fait il était impossible de modifier le layout (modification du fichier .xkb + redémarrage > toujours les anciennes touches… jusqu'à ce que je tape la commande setxkbmap fr bepo, et encore pas toujours).

Une solution qui marche pour moi, modifier le layout dans /etc/default/console-setup, comme indiqué ici

Sinon essayes avec XFCE, je n'ai pas eu de problèmes avec smile

Dernière modification par Calmacil (31/3/2011 10:33:57)

Hors ligne

#4 31/3/2011 11:41:56

jemini
Membres
Inscription : 31/3/2011
Messages : 4

Re : Problème clavier bépo touche TLDE (numbersign/dollars) [RESOLU]

Merci pour vos réponses.

Le bépo est bien pris en compte que ce soit par gnome ou par le console. Seule la touche TLDE n'est pas correctement configurée. 0r, dans système->préférences->clavier, j'ai bien :

http://rd-microfilms.net/rig/Capture.png

J'arrive à retrouver les fichiers de config où l'on peux spécifier le type de clavier (dans la doc de bépo.fr, cela est bien expliqué). Par contre, impossible de savoir où se trouve le fichier de config du mapping clavier unifié console/gnome utilisé par gnome et gnome ne semble proposer aucun outils pour adapter le mapping à ses besoins (ou au moins rectifier les erreurs)…

C'est moi où gnome pratique l'obfuscation pour perde tout le monde ?!

J.

Hors ligne

#5 31/3/2011 12:26:54

Calmacil
Membres
Inscription : 18/2/2011
Messages : 12

Re : Problème clavier bépo touche TLDE (numbersign/dollars) [RESOLU]

Comme je le disais, c'est le même problème que j'ai eu sous KDE…

Hors ligne

#6 31/3/2011 13:56:12

jemini
Membres
Inscription : 31/3/2011
Messages : 4

Re : Problème clavier bépo touche TLDE (numbersign/dollars) [RESOLU]

Calmacil a écrit :

Comme je le disais, c'est le même problème que j'ai eu sous KDE…

J'ai bien regardé  ici. Or mon fichier /etc/default/console-setup a les bons paramètres, confirmé par le fait que mon clavier bépo fonctionne :

# /etc/default/console-setup
…
# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.
XKBMODEL="tm2030USB"
XKBLAYOUT="fr"
XKBVARIANT="bepo"
XKBOPTIONS="grp:alts_toggle,eurosign:e,caps:shift,lv3:lwin_switch,grp_led:caps"

De plus, le mapping ne se configure pas dans ce fichier sad

La vraie question est :

Où configure-t'on le mapping (comprendre l'association des lettres au touches) sous gnome comme on pouvait le faire naturellement sous X dans le fichier /usr/share/X11/xkb/symbols/fr ?!

Hors ligne

#7 31/3/2011 14:10:16

Calmacil
Membres
Inscription : 18/2/2011
Messages : 12

Re : Problème clavier bépo touche TLDE (numbersign/dollars) [RESOLU]

jemini a écrit :

De plus, quand je lance la commande setxkbmap fr bepo, je retrouve les signes numbersign/dollars sous TLDE.

Essayes de mettre ta commande dans ton .xinitrc smile

Hors ligne

#8 31/3/2011 14:44:29

jemini
Membres
Inscription : 31/3/2011
Messages : 4

Re : Problème clavier bépo touche TLDE (numbersign/dollars) [RESOLU]

Victoire big_smile !!!

Mon home utilisateur contenait (pour une raison inconnue) un .Xmodmap contenant entre autre la ré-attribution de la touche TLDE (49) :

…
keycode 94 = at numbersign
keycode 49 = less greater less greater less greater

j'ai donc supprimé cette ré-attribution et hop ! tout est rentré dans l'ordre !

Du coups, j'en ai appris un peu plus sur le mapping clavier sous gnome et en particulier sur l'utilisation de xmodmap.

Merci pour votre aide et que cela puisse servir à d'autres smile

J.

Hors ligne

Pied de page des forums