Forum bépo

Forum des utilisateurs du bépo

Vous n'êtes pas identifié(e).

#1 7/5/2011 17:29:44

damien thiriet
Membres
Lieu : Varsovie
Inscription : 2/9/2010
Messages : 143
Site Web

disposition personnelle et xkbcomp

Bonjour,

J'utilise une variante personnelle du bepo, que j'avais enregistré dans le fichier fr de xkb/symbols. Cela marche très bien, sauf que ma disposition disparait à chaque mise à jour. J'ai donc fait un poste sur le forum archlinux et on m'a conseillé la méthode du wiki du bépo (http://bepo.fr/wiki/X.Org_portable). Je l'ai appliqué mais j'obtiens un clavier qui ne gère pas Alt-g et les flèches. Par précaution, j'ai répété la même procédure avec les fichiers du wiki et… bis repetita!
Cela veut dire soit
-que j'ai un problème de rang de dossier (je compile dans un .bepo de mon /home). J'ai pourtant fait les modifications du XCompose.
- qu'il y a une erreur dans le fichier à télécharger du wiki
ou autre chose, restons prudents…

Évidemment, si vous connaissez un moyen d'intégrer directement un fichier de type symbol sans compiler ce sera encore plus simple — même si cela laisserait en plan la question de la procédure du wiki qui ne marche pas…
Merci d'avance!


TM 2030, bépo depuis 2010
Open BSD - pdksh - ratpoison + dmenu + tmux + st - Vim - zathura ou mupdf - imv ou sxiv - keynav
ma page du wiki

Hors ligne

#2 7/5/2011 18:20:18

damien thiriet
Membres
Lieu : Varsovie
Inscription : 2/9/2010
Messages : 143
Site Web

Re : disposition personnelle et xkbcomp

J'ai résolu le problème en remplaçant include "xfree86+aliases(azerty") par include "evdev+aliases(azerty)". Je ne sais pas si evdev a remplacé xfree86. Est-ce le cas?
Quand j'aurais le temps, j'écrirai une page wiki sur l'installation d'une configuration bidouillée…


TM 2030, bépo depuis 2010
Open BSD - pdksh - ratpoison + dmenu + tmux + st - Vim - zathura ou mupdf - imv ou sxiv - keynav
ma page du wiki

Hors ligne

#3 7/5/2011 18:44:41

Laurent
Membres
Inscription : 9/8/2009
Messages : 709
Site Web

Re : disposition personnelle et xkbcomp

Bonjour,

damien thiriet a écrit :

J'ai résolu le problème en remplaçant include "xfree86+aliases(azerty") par include "evdev+aliases(azerty)".

C'est exactement ce qu'il faut.

damien thiriet a écrit :

Je ne sais pas si evdev a remplacé xfree86. Est-ce le cas?

Ça concerne uniquement le pilote du clavier : soit le pilote clavier standard d'X.org, soit evdev.
Mais les distributions récentes utilisent plutôt evdev (notamment parce qu'il gère mieux l'ajout à chaud de claviers ou souris USB).

damien thiriet a écrit :

Quand j'aurais le temps, j'écrirai une page wiki sur l'installation d'une configuration bidouillée…

L'idéal serait que le pilote portable gère les deux. À défaut que la manipulation soit au moins indiquée dedans.
Mais pour ça, il faut l'accès en écriture sur le site de téléchargement.
Si tu veux faire du wiki, le mieux serait de modifier directement la page comprenant les instructions d'installation, afin que les personnes suivantes qui voudront utiliser ce pilote ne ratent pas l'info.

C'est un problème connu depuis longtemps (voir ici par exemple).
Il ne devrait plus se poser si le pilote portable pour Linux était maintenu (il ne correspond d'ailleurs pas tout-à-fait à la version considérée comme finale du Bépo)...

Hors ligne

Pied de page des forums