Forum bépo

Forum des utilisateurs du bépo

Vous n'êtes pas identifié(e).

#1 10/3/2016 19:54:38

Stanzer
Membres
Inscription : 5/3/2016
Messages : 29

[Résolu] TypeMatrix 2030 - Pavé numérique

Bonjour,

C'est encore moi, avec un nouveau problème…

Depuis que j'ai installé ma nouvelle tablette Wacom, le fonctionnement du pavé numérique a changé. Je ne suis pas certain que ça soit lié, mais étant donnée la concomitance des deux événements, je présume que si.

Désormais, je dois – en plus de Fn ou VerrNum – presser la touche Maj pour obtenir mes chiffres par le pavé. Mais ce comportement n'apparaît qu'une fois loggé. En effet, sur l'écran de connexion LightDM, le fonctionnement du pavé est « normal ».

Je précise que j'ai dû compiler les pilotes de la tablette (elle est trop récente pour être reconnue), et que donc, je ne peux pas les désinstaller, tout au plus, la débrancher. J'ajoute que peu importe que la tablette soit branchée ou non, le fonctionnement reste identique à ce qui est décrit ci-dessus…

Merci d'avance pour chaque petit bout d'info que vous pourrez me donner à ce sujet.

Stan

Dernière modification par Stanzer (11/3/2016 15:49:07)


Ubuntu 16.04 - TypeMatrix 2030

Hors ligne

#2 10/3/2016 23:56:38

Laurent
Membres
Inscription : 9/8/2009
Messages : 727
Site Web

Re : [Résolu] TypeMatrix 2030 - Pavé numérique

Bonjour,

Si tu démarres sur un système live sur clé USB, as-tu le même souci (c’est pour écarter un problème matériel) ?

Peux-tu créer un autre compte utilisateur pour tester (au cas où ce serait lié à des paramètres de ton compte) et voir si ça le fait aussi avec lui ?

Qu’indique la commande setxkbmap -print ?

Qu’as-tu comme trace avec xev ?

Pour les deux dernières questions, comparer avec l’équivalent produit dans des conditions qui ne posent pas le problème (même si c’est seulement le système sur clé USB) pourrait donner des indications intéressantes.

Hors ligne

#3 11/3/2016 10:00:10

Stanzer
Membres
Inscription : 5/3/2016
Messages : 29

Re : [Résolu] TypeMatrix 2030 - Pavé numérique

Laurent a écrit :

Bonjour,

Si tu démarres sur un système live sur clé USB, as-tu le même souci (c’est pour écarter un problème matériel) ?

Peux-tu créer un autre compte utilisateur pour tester (au cas où ce serait lié à des paramètres de ton compte) et voir si ça le fait aussi avec lui ?

Aucun problème en USB, ni avec un nouveau compte de test, où tout foctionne.

Laurent a écrit :

Qu’indique la commande setxkbmap -print ?

~$ setxkbmap -print

xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(azerty)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+fr(bepo)+inet(evdev)"	};
	xkb_geometry  { include "pc(pc105)"	};
};

Voici ce que me donne la même commande dans le compte de test où tout fonctionne normalement :

	
xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(azerty)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+fr(bepo)+fr(oss):2+us:3+inet(evdev)"	};
	xkb_geometry  { include "pc(pc105)"	};
};
Laurent a écrit :

Qu’as-tu comme trace avec xev ?

Voici ce que retourne xev, en tapant sur le pavé successivement (Fn + 1 2 3), puis (Fn + Maj + 1 2 3)

KeyPress event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2668072, (102,-14), root:(1842,38),
    state 0x0, keycode 87 (keysym 0xff9c, KP_End), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2668208, (102,-14), root:(1842,38),
    state 0x0, keycode 87 (keysym 0xff9c, KP_End), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2668296, (102,-14), root:(1842,38),
    state 0x0, keycode 88 (keysym 0xff99, KP_Down), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2668440, (102,-14), root:(1842,38),
    state 0x0, keycode 88 (keysym 0xff99, KP_Down), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2668504, (102,-14), root:(1842,38),
    state 0x0, keycode 89 (keysym 0xff9b, KP_Next), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2668592, (102,-14), root:(1842,38),
    state 0x0, keycode 89 (keysym 0xff9b, KP_Next), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2679384, (102,-14), root:(1842,38),
    state 0x0, keycode 50 (keysym 0xffe1, Shift_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2679880, (102,-14), root:(1842,38),
    state 0x1, keycode 87 (keysym 0xffb1, KP_1), same_screen YES,
    XLookupString gives 1 bytes: (31) "1"
    XmbLookupString gives 1 bytes: (31) "1"
    XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2680008, (102,-14), root:(1842,38),
    state 0x1, keycode 87 (keysym 0xffb1, KP_1), same_screen YES,
    XLookupString gives 1 bytes: (31) "1"
    XFilterEvent returns: False

KeyPress event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2680112, (102,-14), root:(1842,38),
    state 0x1, keycode 88 (keysym 0xffb2, KP_2), same_screen YES,
    XLookupString gives 1 bytes: (32) "2"
    XmbLookupString gives 1 bytes: (32) "2"
    XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2680224, (102,-14), root:(1842,38),
    state 0x1, keycode 88 (keysym 0xffb2, KP_2), same_screen YES,
    XLookupString gives 1 bytes: (32) "2"
    XFilterEvent returns: False

KeyPress event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2680336, (102,-14), root:(1842,38),
    state 0x1, keycode 89 (keysym 0xffb3, KP_3), same_screen YES,
    XLookupString gives 1 bytes: (33) "3"
    XmbLookupString gives 1 bytes: (33) "3"
    XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2680456, (102,-14), root:(1842,38),
    state 0x1, keycode 89 (keysym 0xffb3, KP_3), same_screen YES,
    XLookupString gives 1 bytes: (33) "3"
    XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x5600001,
    root 0x4ae, subw 0x0, time 2680728, (102,-14), root:(1842,38),
    state 0x1, keycode 50 (keysym 0xffe1, Shift_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

FocusOut event, serial 37, synthetic NO, window 0x5600001,
    mode NotifyGrab, detail NotifyNonlinear

FocusIn event, serial 37, synthetic NO, window 0x5600001,
    mode NotifyUngrab, detail NotifyNonlinear

KeymapNotify event, serial 37, synthetic NO, window 0x0,
    keys:  2   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   

Merci pour ton aide

Dernière modification par Stanzer (11/3/2016 10:12:22)


Ubuntu 16.04 - TypeMatrix 2030

Hors ligne

#4 11/3/2016 15:21:41

Laurent
Membres
Inscription : 9/8/2009
Messages : 727
Site Web

Re : [Résolu] TypeMatrix 2030 - Pavé numérique

Le paramétrage (donné par setxkbmap -print) du clavier est normal. Accessoirement le compte de test a des dispositions multiples (même le Qwerty ! les réglages clavier de Gnome ont encore frappé), mais ça n’a pas de relation avec le problème.

Les événements affichés par xev indiquent que tu es bien sur le pavé numérique, mais pas en mode numérique (donc il fait office de pavé curseur).

Le verrouillage numérique du système n’est apparemment pas dans le bon état par rapport au verrouillage du pavé numérique interne au clavier. Soit tes réglages clavier mettent le verrouillage numérique du système dans la mauvaise position, soit ils se contentent de rappeler la position précédente mais ce n’est pas la bonne.

Je ne sais pas s’il y a un moyen sur le TypeMatrix de changer l’état du verrouillage numérique du système et du verrouillage du pavé du clavier indépendamment (je n’ai pas de TypeMatrix 2030).

Je vois deux possibilités pour régler le problème dans l’immédiat :
– brancher un clavier classique (avec un pavé numérique physique), taper sur Verr. Num. dessus et le débrancher ;
– utiliser la commande numlockx off.

Si tu installes la commande numlockx, il faut mettre

NUMLOCK=off

dans le fichier /etc/default/numlockx .

Par ailleurs, ça devrait résoudre le problème pour les prochaines sessions… sauf si quelque chose réactive le verrouillage numérique derrière lui.

Si ça revient à la prochaine session, tu dois avoir un réglage clavier quelque part qui réactive le verrouillage numérique du système à l’ouverture de session. Il faut le trouver et le désactiver.
Si l’on considère que l’autre compte utilisateur a trois dispositions de clavier et le tien seulement une, ne serais-tu pas resté sous Xfce ? Dans ce cas, désactiver « Restaurer l’état du verrouillage numérique au démarrage » dans les paramètres clavier pourrait résoudre le problème.

Hors ligne

#5 11/3/2016 15:44:41

Stanzer
Membres
Inscription : 5/3/2016
Messages : 29

Re : [Résolu] TypeMatrix 2030 - Pavé numérique

Laurent a écrit :

Je vois deux possibilités pour régler le problème dans l’immédiat :
– brancher un clavier classique (avec un pavé numérique physique), taper sur Verr. Num. dessus et le débrancher ;
– utiliser la commande numlockx off.

Woahou ! big_smile

Ça marche. J'avais en effet branché un second clavier azerty pour booter dans une VM avec un MdP tordu que j'avais entré en qwery sans le savoir. Et j'avais effectivement dû passer par VerrNum pour activer le pavé numérique sur ce second clavier, alors qu'il était évidemment déjà activé sur la machine hôte. J'imagine donc que c'est en faisant cette manip que ça a inversé le numlock de l'hôte.

J'ai donc rebranché ce second clavier, tapé VerrNum, et voilà, tout est revenu à la normale. Merci d'avoir pris le temps de rédiger une réponse aussi longue et précise.

Je vais aussi poster ta réponse en lien sur le forum Typematrix où j'avais aussi posé cette question (mais en anglais).

Merci bcp, cool

Stan.

Dernière modification par Stanzer (11/3/2016 19:32:34)


Ubuntu 16.04 - TypeMatrix 2030

Hors ligne

#6 11/5/2021 21:38:52

Anthony
Nouveaux membres
Inscription : 11/5/2021
Messages : 1

Re : [Résolu] TypeMatrix 2030 - Pavé numérique

Bonjour,

Juste pour dire que même après 5 ans ce post est toujours bien utile.

Passé de KDE à Gnome, je ne comprenais pas pourquoi le pavé numérique ne fonctionnait plus.
Après avoir activé VerrNum sur le clavier du PC portable tout est rentré dans l’ordre,

Merci.


Manjaro Gnome - TypeMatrix 2030 / Tout neuf dans le monde du bépo

Hors ligne

Pied de page des forums